Timeout during connect (likely firewall problem)

My domain is:

It produced this output:
Failed to validate challenge for dns:linearbench.com: Status is "invalid". Challenge http-01: Error urn:ietf:params:acme:error:connection: " Fetching http://linearbench.com/.well-known/acme-challenge/MoEiKNKY0u0_nZ3AdJn1Mqjh8wEv88EK5_iVxXfqItk: Timeout during connect (likely firewall problem)\

My web server is (include version):

The operating system my web server runs on is (include version):
Ubuntu 20.04

My hosting provider, if applicable, is:

I can login to a root shell on my machine (yes or no, or I don't know):

I'm using a control panel to manage my site (no, or provide the name and version of the control panel):

I can access the domain without issue through internet however https://letsdebug.net/ returned error on this domain. How can I find the problem? Thanks in advance.

1 Like

A couple ideas.

One, your IP is related to Cox networks. Is that the right IP ( for your server? I wonder because you said your hosting service is GoDaddy. Is GoDaddy your server host or just your DNS registrar?

Two, do you have any firewall that is blocking certain IP ranges? Because I can see it from my test server. And, Let's Debug saw it from its own test server (look at its detail results). But, the actual Let's Encrypt Server sites (staging and prod) are not able to connect to you.

Another test site I use saw it only from 3 of 5 tested regions around the world.


Thanks for the ideas Mike! They are helpful. Yes our ip is and our network provider is cox. Godadday is the DNS register but not server host. We have our own hosting server.

I disabled firewall on the server but it still did not work. Probably IpFire has bloked some ips. I need to check with my colleague.

1 Like

That seems like the most likely situation.
My IP can reach your system via HTTP:

curl -Ii linearbench.com
HTTP/1.1 200 OK
Server: nginx/1.23.1
Date: Fri, 12 Aug 2022 21:17:44 GMT
Content-Type: text/html
Content-Length: 615
Last-Modified: Tue, 19 Jul 2022 14:05:27 GMT
Connection: keep-alive
ETag: "62d6ba27-267"
Accept-Ranges: bytes

Yeah But...

22/tcp  filtered ssh
80/tcp  open     http
443/tcp closed   https

Just an observation.

Somehow I disabled location block and enabled it on IPFire and everything works.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.