This site can’t be reached

After install Let’s Encrypt with Certbot, I can not visit my website, and get “This site can’t be reached. took too long to respond.” Please help.

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g., so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is:

I ran this command:sudo certbot --authenticator webroot --installer nginx

It produced this output:Congratulations! You have successfully enabled

My web server is (include version):nginx/1.10.1

The operating system my web server runs on is (include version):

My hosting provider, if applicable, is:Ubuntu 14.04.5

I can login to a root shell on my machine (yes or no, or I don’t know):Yes

I’m using a control panel to manage my site (no, or provide the name and version of the control panel):eyes:

Your server is not responding to connections on port 443/tcp.

Check your server’s firewall.

Hi! Since I’m at work I only could test with Safari-Browser on iOS: - does work for me but I got an certificate Error (cannot reproduce it since I accepted it).
Did you register the certificate only for but not for - does not work for me and runs to timeout.
Did you configure the alias (without www.) in your webserver? Is there a valid domain redirection for without www. prefix?

Good catch - it is using Free Naked Domain Redirect on , which explains why it does not listen on 443/tcp.

@vincentopensourcetai the redirect service does not support HTTPS so you will need to either go without SSL on the www-less domain, or stop using wwwizer.

I remove the wwwizer already.

However, I get “Your connection is not private
Attackers might be trying to steal your information from (for example, passwords, messages, or credit cards). Learn more

You will need to re-run the original certbot command you used, but include the correct domains you want on the certificate.

e.g for just the www one:


instead of:


Or if you want both (and you setup DNS for without using wwwizer):

-d -d

1 Like

It works now, thank you very much.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.