There was a problem processing your request

Hi,

I have a main domain "studio-och.com" pointing to a static site on Netlify.
I created a subdomain "cms.studio-och.com" pointing to my hosting with a Headless Wordpress.

I want to force HTTPS for my subdomain, but I faced with this error, and I can't create my certificate.

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. https://crt.sh/?q=example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is: studio-och.com
But I'm trying to force HTTPS to my subdomain: cms.studio-och.com

I ran this command: Let's Encrypt™ SSL - Issue

It produced this output: There was a problem processing your request

Error issuing certificate
Failed to issue certificate
Updating challenge for studio-och.com: acme: error code 403 "urn:ietf:params:acme:error:unauthorized":
Invalid response from https://studio-och.com/.well-known/acme-challenge/7vgDVl1OXEZzN0rLLYCBzPyS4ThR8dgptqTBs2lfCrw [104.198.14.52]: "\n<!doctype html>\n<html lang="en" data-n-head="%7B%22lang%22:%7B%221%22:%22en%22%7D%" (order URL: https://acme-v02.api.letsencrypt.org/acme/order/109094070/7255991869)

My web server is (include version): CPanel 92.0, Apache 2.4.46, Perl 5.16.3

The operating system my web server runs on is (include version): Linux

My hosting provider, if applicable, is: Netsons

I can login to a root shell on my machine (yes or no, or I don't know): No

I'm using a control panel to manage my site (no, or provide the name and version of the control panel): CPanel 92.0

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you're using Certbot):

Hi and welcome to the LE community forum :slight_smile:

You say that you are trying to get a cert for:

But the LE failure shows the root domain and IP:

I believe the fix may be found in:

But it has to be running at the IP of:

Name:    cms.studio-och.com
Address: 89.40.172.86

Otherwise, you might be able to handle it in:

For that route, start with showing the output of:
apachectl -S

Yes my root domain is studio-och.com. Netlify has add a SSL certificate to my main domain. Now i want to configure my subdomain certificate.

We are in agreement and I already understand that from your opening post.
I gave you some direction, did you understand me?
You need to execute the command to get the cert on the system:

Name:    cms.studio-och.com
Address: 89.40.172.86

Okkey Thanks,
I run the command on my terminal or somewhere else ?

I dont't have any droplet with SSH.

From my terminal the output is:
VirtualHost configuration:
ServerRoot: "/usr"
Main DocumentRoot: "/Library/WebServer/Documents"
Main ErrorLog: "/private/var/log/apache2/error_log"
Mutex default: dir="/private/var/run/" mechanism=default
Mutex mpm-accept: using_defaults
PidFile: "/private/var/run/httpd.pid"
Define: DUMP_VHOSTS
Define: DUMP_RUN_CFG
User: name="_www" id=70 not_used
Group: name="_www" id=70 not_used

Can you SSH into 89.40.172.86 ?

Nope my client has selected the Hosting Web 100 from netsons, without SSH connection:

Here you can view the domain settings.

Main domain "studio-och.com" pointing to Netlify IP
And "cms.studio-och.com" pointing to Server IP with Wordpress

Schermata-2021-01-11-alle-19-33-13

You may need to solve this in cPanel.
[like I said in my first post]

The link shows that it supports Let's Encrypt.
Maybe their website has some howto instructions.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.