There is not green padlock on the bar


#1

hello i install correctly the ceftificat yesterday, and i still wait that the green padlock appear but not appear on the bar web adress


#2

Your site’s front page seems to be redirecting from HTTPS to HTTP. It should be redirecting from HTTP to HTTPS.

If you need help with changing that, please share the Apache configuration for that domain.


#3

i don’t know what is the apache configuration? please help


#4

Your website seems to be using the Apache web server, is that correct? What operating system is it using? The redirect might be in a .htaccess file, or it might be in your Apache configuration files which are usually in /etc/httpd/ or /etc/apache2/ but might be in different places depending on your operating system.

You already have a valid Let’s Encrypt certificate. If you don’t know about Apache configuration, did you use Certbot to automatically configure Apache for you? Or perhaps a control panel provided by your hosting company?


#5

i have a cpanel of viewen web hosting , i try to force redirect by adding some lines to .htacces file:
RewriteCond %{HTTP_HOST} [NC]
RewriteCond %{SERVER_PORT} 80
RewriteRule ^(.*)$ https://$1 [R,L]

, but the website not appear , only the green padlock appear but the website is off, i delete again this lines on .htaaces and the website is on but the green padlock not apear !!!


#6

Right, so the redirect you added is correct, redirecting HTTP to HTTPS, but there’s another redirect somewhere else, and it’s redirecting back to HTTP again. So when they’re both enabled, you get redirected back and forth and back and forth and the website never appears.

What you need to do is find the other redirect, and remove it. Then add the good one back in again.

If you can’t find it anywhere in .htaccess or in your Apache configuration, there might be a setting somewhere in the application you’re using (prestashop?) for a base URL that might be set to http:// and could need to be changed to https://


#7

ooh thank you very much. i love you

it’s work now


#8

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.