The server could not connect to the client to verify the domain

Hello,

I ran this command: sudo certbot --apache -d nl.maxviril.com

It produced this output:
Failed authorization procedure. nl.maxviril.com(http://nl.maxviril.com) (http-01): urn:ietf:params:acme:error:connection :: The server could not connect to the client to verify the domain :: Fetching http://nl.maxviril.com/.well-known/acme-challenge/ca_btS326IBsCXATpBT2Nd7ZbqWG592wC1GLgTjllmg: Timeout during connect (likely firewall problem)

My web server is (include version):apache2

The operating system my web server runs on is (include version):Ubuntu 18.04

I can login to a root shell on my machine (yes or no, or I don’t know): yes

I’m using a control panel to manage my site (no, or provide the name and version of the control panel):no

sudo certbot certificates showing there are not certs found.

The error show “likely firewall problem”, but there are no firewall on my server.

Can you help me please ?

Patrick.

Hi

There might be a glich and all things loooked normal.
Could you please try again now?

Thank you

Thank you to answer…

I have tried, but there is still the same problem…

root@dev:/etc/apache2/sites-available# sudo certbot --apache -d nl.maxviril.com Saving debug log to /var/log/letsencrypt/letsencrypt.log
Plugins selected: Authenticator apache, Installer apache
Obtaining a new certificate
Performing the following challenges:
http-01 challenge for nl.maxviril.com
Waiting for verification…
Cleaning up challenges
Failed authorization procedure. nl.maxviril.com (http-01): urn:ietf:params:acme:error:unauthorized :: The client lacks sufficient authorization :: Invalid response from http://nl.maxviril.com/.well-known/acme-challenge/g0BMEK2hYsfzafFIOSd3TmRdtHIHeAJuFwNaKJRZ1Q0 [165.22.92.102]: “\n\n404 Not Found\n\n

Not Found

\n<p”

IMPORTANT NOTES:

Those are TWO different problems.

The second it better than the first, so you are moving in the right direction.
Now you just need to match the location where the challenge files are being placed to the location where the Internet challenge requests are being served from.

Here are some "commands" that can help determine, or set, possible locations:
[in no particular order]
apachectl -S

grep -Eri 'documentroot|servername|serveralias|listen|virtual|return|rewrite' /etc/apache2/

Alias /.well-known/acme-challenge/ /some/dedicated/path/
--webroot -w /actual/DocumentRoot/location/

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.