The requested DNS plugin does not appear to be installed

I am trying to install an SSL certificate for the root domain along with a wildcard for all subdomains.

My domain is: makersite.co

I ran this command:
sudo certbot -a dns-digitalocean -i apache -d "*.makersite.co" -d makersite.co --server https://acme-v02.api.letsencrypt.org/directory

It produced this output (even though I have installed the plugin):
The requested dns-digitalocean plugin does not appear to be installed

I then tried running this code:
certbot certonly -dns-digitalocean -dns-digitalocean-credentials ~/.secrets/certbot/digitalocean.ini -d makersite.co -d *.makersite.co

Which produced this output:
certbot: error: unrecognized arguments: /home/ozzie/.secrets/certbot/digitalocean.ini

My web server is (include version): Apache

The operating system my web server runs on is (include version): Ubuntu 18.04

My hosting provider, if applicable, is: DigitalOcean

This is the tutorial I was following: https://certbot.eff.org/lets-encrypt/ubuntubionic-apache

The issue is with dns-digitalocean plugin not working/or apparently being installed as intended.

note: I am trying to get an SSL certificate for the wildcard subdomains along with the root domain.

Also, I used the following code on another domain that I have (on a different server but same configuration) and it worked though I had to manually renew every 3 months rather than automatic which is why I am following the new tutorial:
./certbot-auto certonly --manual -d *.example.co -d example.co --preferred-challenges dns-01 --server https://acme-v02.api.letsencrypt.org/directory

Hi @ozzie

the documentation

says:

 --dns-digitalocean    Obtain certificates using a DNS TXT record (if you are
                        using DigitalOcean for DNS). (default: False)

So use two --.

Same with the credentials parameter.

How did you install Certbot?

If you used apt, did you install the python3-certbot-dns-digitalocean plugin package?

What does “sudo which certbot” show?

Thanks for the reply, I tried that though I get the same error:
certbot: error: unrecognized arguments: --dns-digitalocean-credentials /home/ozzie/.secrets/certbot/digitalocean.ini

After running:
sudo certbot certonly --dns-digitalocean --dns-digitalocean-credentials ~/.secrets/certbot/digitalocean.ini -d makersite.co -d *.makersite.co

I installed Certbot through sudo apt-get install certbot python-certbot-apache: following the tutorial here

pip install python3-certbot-dns-digitalocean returned a “Not found” error so I installed the plugin through pip install certbot-dns-digitalocean

sudo which certbot returns /usr/bin/certbot

Installing parts of Certbot with apt-get and other parts with pip is likely to fail eventually when some of them get updated and the versions diverge too far.

How could I resolve that?

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.