`The requested dns-cloudflare plugin does not appear to be installed`

My domain is: huelet.net

I ran these commands:

sudo snap install --classic certbot
sudo snap install certbot-dns-cloudflare
certbot certonly --dns-cloudflare

It produced this output:

The requested dns-cloudflare plugin does not appear to be installed

My web server is (include version): OLS 1.6.18

The operating system my web server runs on is (include version): CentOS 7

My hosting provider, if applicable, is: Cloudflare

I can login to a root shell on my machine (yes or no, or I don't know): yes

I'm using a control panel to manage my site (no, or provide the name and version of the control panel): no

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you're using Certbot): 1.11.0

Basically, I'm trying to use the Cloudflare plugin.
But Certbot says it's not installed. Ok, so I run sudo snap install certbot-dns-cloudflare which returns:

snap "certbot-dns-cloudflare" is already installed, see 'snap help refresh'

So what's going on?

1 Like

How's it going, Levi? :slightly_smiling_face:

Try running these:

sudo ln -s /snap/bin/certbot /usr/bin/certbot

sudo snap set certbot trust-plugin-with-root=ok

Then try running this:

sudo certbot certonly --dns-cloudflare

You'll need to refer to the certbot dns-cloudflare documentation to setup your Cloudflare credentials.

1 Like

sudo ln -s /snap/bin/certbot /usr/bin/certbot returns

ln: failed to create symbolic link ‘/usr/bin/certbot’: File exists
1 Like

I think @griffin was trying to "force" your command line to use the snap version of certbot in the case /usr/bin/certbot was still pointing to an older version of certbot (i.e., installed by other means). I'm guessing this isn't necessary, but it's also good to verify:

ls -l /usr/bin/certbot

If the commands in your OP are indeed the actual commands and none were left out, you didn't follow the certbot instructions for DNS plugis correctly. Indeed, the step mentioned by @griffin regarding the trust-plugin-with-root=ok is mandatory for plugins to work succesfully.

Although I must admit, the tab "wildcard" is a little bit of a misnomer if you don't actually require a wildcard certificate but do want the instructions for the DNS plugin.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.