Certbot-dns-cloudflare installed but not working

Hi. I am getting an error with using the certbot-dns-cloudflare plugin. I have already installed it using the command: snap install certbot-dns-cloudflare and run the other commands in the Certbot instructions before doing that. Snap reports that the plugin is installed, and I can find the files in my snap folder, but Certbot can't seem to find it. Here is the rundown of my current situation:

My domain is: mcadmin.drewssite.top (not serving a site as of now)

I ran this command: sudo certbot certonly --dns-cloudflare -d drewssite.top

It produced this output:

Saving debug log to /var/log/letsencrypt/letsencrypt.log Could not choose appropriate plugin: The requested dns-cloudflare plugin does not appear to be installed

My web server is (include version): Apache2

The operating system my web server runs on is (include version): Ubuntu 20.04

My hosting provider, if applicable, is: self-hosted

I can login to a root shell on my machine (yes or no, or I don't know): yes

I'm using a control panel to manage my site (no, or provide the name and version of the control panel): no

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you're using Certbot): Certbot 0.40.0

I also previously ran a command with credentials, but it said the credentials option was not recognized. I assume this is because it doesn't think the plugin is installed

Hi @foxler2010, and welcome to the LE community forum :slight_smile:

I don't think snap installs can be used by that outdated version.
Can you update the version to latest?


You're probably running multiple installations of Certbot. Please uninstall all versions of Certbot installed using apt and continue with the snap version only.


That fixed it! Thanks for the help!


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.