The error was: PluginError('There has been an error in parsing the file /etc/apache2/sites-enabled/ on line 132: Syntax error')

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. |, so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is:

I ran this command:: sudo certbot -i apache

It produced this output:
Saving debug log to /var/log/letsencrypt/letsencrypt.log

How would you like to authenticate with the ACME CA?

1: Obtain certificates using a DNS TXT record (if you are using Cloudflare for
DNS). (dns-cloudflare)
2: Spin up a temporary webserver (standalone)
3: Place files in webroot directory (webroot)

Select the appropriate number [1-3] then [enter] (press 'c' to cancel): 3
The apache plugin is not working; there may be problems with your existing configuration.
The error was: PluginError('There has been an error in parsing the file /etc/apache2/sites-enabled/ on line 132: Syntax error')

My web server is (include version): Apache/ 2.4.41

The operating system my web server runs on is (include version): Linux Mint 20.2 Uma

My hosting provider, if applicable, is:

I can login to a root shell on my machine (yes or no, or I don't know): Yes

I'm using a control panel to manage my site (no, or provide the name and version of the control panel): No

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you're using Certbot): certbot 1.17.0

Here is the file Line 132 is a commented part of the file

I am migrating to a fresh webserver after my old one died and I am restoring the files this from a backup. certbot worked fine but now this error happens

1 Like

I'll look into the syntax error and your configuration file momentarily, but I've got a different question too: is there a reason why you're using -i apache to only select the apache installer plugin and at the question from certbot select the webroot authenticator?

Also, I'm a little bit puzzled why the apache authenticator isn't listed in that list of options.. :thinking:

I'm not able to reproduce your syntax error, but that might be due to the fact I had to copy/paste the contents of the pastebin, as that Ubuntu pastebin site is a REAL #()#)($( PAIN IN THE ()#$()#( requiring the user to login to view the plain text file and it's utterly impossible to download the file.. If you try, you'll get a HTML page to login again......... So perhaps by copy/pasting it, some errors tripping the certbot parser has been removed..


The fact that copy paste fixes this is astounding

1 Like

Ah, so it worked for you too? Glad to hear! Perhaps it was some kind of encoding issue..


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.