The Certificate Authority failed to verify the temporary nginx configuration changes made by Certbot

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. |, so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is:

I ran this command: ./

It produced this output:
Saving debug log to /var/log/letsencrypt/letsencrypt.log

Processing /etc/letsencrypt/renewal/

Renewing an existing certificate for

Certbot failed to authenticate some domains (authenticator: nginx). The Certificate Authority reported these problems:
Type: connection
Detail: Fetching Timeout during connect (likely firewall problem)

Hint: The Certificate Authority failed to verify the temporary nginx configuration changes made by Certbot. Ensure the listed domains point to this nginx server and that it is accessible from the internet.

Failed to renew certificate with error: Some challenges have failed.

All renewals failed. The following certificates could not be renewed:
/etc/letsencrypt/live/ (failure)

1 renew failure(s), 0 parse failure(s)
Ask for help or search for solutions at See the logfile /var/log/letsencrypt/letsencrypt.log or re-run Certbot with -v for more details.
Transaction created for certificate /etc/ssl/certs/bundle.pem!

Committing /etc/ssl/certs/bundle.pem......

My web server is (include version): basic Nginx "nginx version: nginx/1.18.0 (Ubuntu)"

The operating system my web server runs on is (include version): Ubuntu 20.04 LTS

My hosting provider, if applicable, is:

I can login to a root shell on my machine (yes or no, or I don't know): yes

I'm using a control panel to manage my site (no, or provide the name and version of the control panel): no

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you're using Certbot): certbot 1.32.2

Hi @Parthipan, and welcome to the LE community forum :slight_smile:
The error message is clear:

Can your site be reached on port 80 from the Internet?


Port 80 is not always open. on request It team can open it for a day. Let me know if you need more information.

Thanks and regards,

1 Like

Port 80 needs to be open for every certificate renewal. It fully explains the error message.


Thanks for your information, I tried renewing the certificate manually while port 80 was open and got these error messages.

1 Like

There's not much else to go on. That is the usual cause for that error message. Try open up port 80 again and we can try see if the port is working from the internet, or not.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.