Help needed, cant renew certbot

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. https://crt.sh/?q=example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is: centroestudiospulmonares.com

I ran this command: certbot -v renew

It produced this output: certbot -v renew
Saving debug log to /var/log/letsencrypt/letsencrypt.log


Processing /etc/letsencrypt/renewal/centroestudiospulmonares.com.conf


Certificate is due for renewal, auto-renewing...
Plugins selected: Authenticator nginx, Installer nginx
Renewing an existing certificate for centroestudiospulmonares.com
Performing the following challenges:
http-01 challenge for centroestudiospulmonares.com
Waiting for verification...
Challenge failed for domain centroestudiospulmonares.com
http-01 challenge for centroestudiospulmonares.com

Certbot failed to authenticate some domains (authenticator: nginx). The Certificate Authority reported these problems:
Domain: centroestudiospulmonares.com
Type: connection
Detail: 18.210.198.221: Fetching http://centroestudiospulmonares.com/.well-known/acme-challenge/fziD7u8t1XAYO_-OiK0Q3UBXE4doPjRJ0K8RPIyH0EM: Timeout during connect (likely firewall problem)

Hint: The Certificate Authority failed to verify the temporary nginx configuration changes made by Certbot. Ensure the listed domains point to this nginx server and that it is accessible from the internet.

Cleaning up challenges
Failed to renew certificate centroestudiospulmonares.com with error: Some challenges have failed.


All renewals failed. The following certificates could not be renewed:
/etc/letsencrypt/live/centroestudiospulmonares.com/fullchain.pem (failure)


letsencrypt.log.txt (32.8 KB)

1 renew failure(s), 0 parse failure(s)
Ask for help or search for solutions at https://community.letsencrypt.org. See the logfile /var/log/letsencrypt/letsencrypt.log or re-run Certbot with -v for more details.
root@ip-172-31-30-176:/etc/letsencrypt/renewal# vi /var/log/letsencrypt/letsencrypt.log

My web server is (include version):nginx 1.24

The operating system my web server runs on is (include version):Ubutu 22.04

My hosting provider, if applicable, is:AWS EC2

I can login to a root shell on my machine (yes or no, or I don't know):yes

I'm using a control panel to manage my site (no, or provide the name and version of the control panel):

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you're using Certbot):2.10.0

Hello @macomeza, welcome to the Let's Encrypt community. :slightly_smiling_face:

Presently I see Port 80 is filtered (i.e. blocked)

$ nmap -Pn -p80,443 centroestudiospulmonares.com
Starting Nmap 7.80 ( https://nmap.org ) at 2024-05-16 09:46 PDT
Nmap scan report for centroestudiospulmonares.com (18.210.198.221)
Host is up (0.086s latency).
rDNS record for 18.210.198.221: ec2-18-210-198-221.compute-1.amazonaws.com

PORT    STATE    SERVICE
80/tcp  filtered http
443/tcp open     https

Nmap done: 1 IP address (1 host up) scanned in 2.04 seconds
2 Likes

Thank you!
I have blocked port 80 to everyone, now I have updated it in my security group and it was solved.
Thanks!

3 Likes

You are welcome @macomeza! :slightly_smiling_face:
Have a pleasant day.

2 Likes