Synology disk cannot reach LE server


#1

My domain is:mystation.cz
I ran this command: Wizard to create new cert.
It produced this output: “Filed to connect Lets Encrypt. Please make sure …”
My web server is (include version): DSM 6.1.7-15284
The operating system my web server runs on is (include version): DSM 6.1.7-15284
My hosting provider, if applicable, is: UPC
I can login to a root shell on my machine (yes or no, or I don’t know):YES
I’m using a control panel to manage my site (no, or provide the name and version of the control panel):YES

Hello can somebody help me with this ? I have redirect port 80 to local address of synology centrum. Is it necessary something else ? Can I resolve this problem deeper ? I cant find any logs… I red some topics here but without any help. (I turned off IPv6.)

Thx

Martin


#2

Can you SSH in?

curl -vvv https://acme-v01.api.letsencrypt.org/directory
host acme-v01.api.letsencrypt.org
traceroute acme-v01.api.letsencrypt.org

#3

Curl with “HTTP OK” reply
host – did you mean ping to host ? if yes - response ok
Traceroute without any responese


#4

Would you be able to show the verbatim output of all 3 commands? The devil is in the details (usually).

Edit: actually, nevermind, I think the error message is just misleading and you cut off the important part:

“Failed to Connect to Let’s Encrypt. Please make sure the domain name is valid.

Your domain doesn’t have any A/AAAA records, it doesn’t resolve.


#5

f.k… thx I fixed it :slight_smile: I had only *.mystation.cz. I have to wait some time to apply and I will let you know if this was problem :slight_smile: thx meanwhile


#6

DNS fixed… issue still exist
Output: https://ulozto.net/!IjGGmOCj1Isf/output-txt
Thx for your time !


#7

What’s the full error message from the wizard now?


#8

The same :expressionless:
“Failed to Connect to Let’s Encrypt. Please make sure the domain name is valid.”


#9

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.