Sudo: letsencrypt: command not found


#1

Hello,

I’m working in the latest Debian environment with Apache2. I have installed Letsencrypt with
git clone https://github.com/letsencrypt/letsencrypt
which went fine as far as I can tell.
Now in my user directory I have a letsencrypt directory. Whether I run it from there or from the user directory, the command
sudo ./letsencrypt --redirect
gives me the error message
sudo: ./letsencrypt: command not found.
But as it looks, all files are there! What am I doing wrong?


#2

The git command will create a clone in the letsencrypt subdirectory so its in a subdirectory:

cd letsencrypt
sudo ./letsencrypt .....

#3

Hi!

There is, in the letsencrypt directory, a letsencrypt-auto script which will automatically update the client, setup the dependencies, and the virtualenv.
This is the recommended way to do this, in absence of a package for your distribution.


#4

PS: There is a letsencrypt package for Debian experimental, but you would have to be ready to deal with bugs and report them in the Debian BTS.


#5

Thanks for the feedback!
sudo ./letsencrypt-auto
run a buckload of commands, installed python etc., but still, when entering
sudo ./letsencrypt --redirect --rsa-key-size 4096
from the same directory still gives the ‘comand not found’ error message :confused:


#6
  1. letsencrypt-auto shouldn’t run as root, it will call sudo as needed.
  2. You should run ./letsencrypt-auto --redirect --rsa-key-size 4096, not try to call letsencrypt directly.
  3. Read the user documentation. It will let you avoid issues like using accidentaly the testing CA rather than the production one.

#7

Houston, I have a problem.
I could get letsencrypt-auto to run fine, there are no error messages as far as I can see, but /etc/ doesn’t have a letsencrypt directory. There doesn’t appear to be any change in the Apache configuration, is it possible this is because it’s managed by Confixx? I created a VirtualHost file for my domain in the /etc/apache2/sites-available directory (with symlink in site-enabled) but no change.

My server runs Debian6-squeeze and Apache 2.


#8

Ok, that’s indeed abnormal.
It might be due to the antiquated Debian version, but I have no idea what it would take to get the ACME client to run on Squeeze.