Sudo ./letsencrypt-auto --debug fails


#1

Hi

I have been trying to get letsencrypt to work on an AWS EC2 instance which I understand is “experimental”. When I issue:

sudo ./letsencrypt-auto --debug

I get the following:

Creating virtual environment...
Updating letsencrypt and virtual environment dependencies......Command 
"/root/.local/share/letsencrypt/bin/python2.7 -c "import setuptools,
 tokenize;__file__='/tmp/pip-build-lGncaX/cffi/setup.py';
exec(compile(getattr(tokenize, 'open', open)(__file__).read().replace('\r\n', '\n'), __file__, 'exec'))"
 install --record /tmp/pip-jdYQdp-record/install-record.txt 
--single-version-externally-managed --compile --install-headers 
/root/.local/share/letsencrypt/include/site/python2.7/cffi" 
failed with error code 1 in /tmp/pip-build-lGncaX/cffi

Anyone else encountered the same and have a fix?

Thanks


#2

Not sure if this was the same reason, but on my instance I was getting the same error.
I had to update python to 2.7 It was 2.6 before.

I followed the step here to update

sudo ./letsencrypt-auto --certonly

Worked afterwards.


#3

@DarkAxi0m thanks for the tip. I will give it a go and post back here the results.


#4

Hi

Yes that’s what it was.

Thanks