Problem in python with aws instance


#1

[root@letsencrypt]# ./letsencrypt-auto --help -debug
Checking for new version…
Creating virtual environment…
Installing Python packages…
Installation succeeded.
Requesting root privileges to run letsencrypt…
/root/.local/share/letsencrypt/bin/letsencrypt --help -debug
Traceback (most recent call last):
File “/root/.local/share/letsencrypt/bin/letsencrypt”, line 7, in
from letsencrypt.main import main
File “/root/.local/share/letsencrypt/local/lib/python2.7/dist-packages/letsencrypt/main.py”, line 11, in
import zope.component
File “/root/.local/share/letsencrypt/local/lib/python2.7/dist-packages/zope/component/init.py”, line 16, in
from zope.interface import Interface


Lost account from letsencrypt - directories - keys - evething
#2

pip install pip --upgrade

pip install virtualenv --upgrade

virtualenv -p /usr/bin/python27 venv27

. venv27/bin/activate

git clone https://github.com/letsencrypt/letsencrypt

cd letsencrypt

./letsencrypt-auto certonly --debug --standalone -d


#3

Uh, are you asking a question? Is your second message saying you run amazon linux?

What is the context of your post?

Without context or a question, it looks like you had a similar problem to me when I updated my python packages in FreeBSD.

To solve the problem, I downgraded my python packages, but they were updated to working versions again within a few days anyway.

I, uh, hope that answers your question :wink:


#4

In first time was a question.
The next post is a solution what i found with help of folks in the github.


#5

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.