Successfully enabled, but now browsers can't connect

Setting up a brand new EC2 instance, got Apache running just fine. Then I installed certbot, had a number of trials and errors, and finally got the SSL installed with a successful completion. However the site would never work under SSL, browsers time out with a Could Not Connect error. http still worked though. Then I ran certbot again, and it behaved like it had not been run before on this site. This time I selected the Enhancement Redirect, and now the http site can’t connect either. Suggestions?

My domain is:

I ran this command: ./certbot-auto

It produced this output: Congratulations! You have successfully enabled and

My web server is (include version): Apache 2

The operating system my web server runs on is (include version): Amazon Linux

My hosting provider, if applicable, is: AWS EC2

I can login to a root shell on my machine (yes or no, or I don’t know): Yes

I’m using a control panel to manage my site (no, or provide the name and version of the control panel): No

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you’re using Certbot): 1.0.0

Check your security group.

HTTPS requires TCP port 443 to be open to the world.

1 Like

Looks like port 443 is NOT open.
AWS firewall must be open as well as local firewall.

Looks like that was the only problem. Thank you!

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.