Subdomain -> NET::ERR_CERT_COMMON_NAME_INVALID


#1

Hi,

I’ve got a mistake, I have a certificate for my domain martin-abadie.fr which works but, for my subdomain cloud.martin-abadie.fr I’ve got the following error in my web-browser Google Chrome :

NET::ERR_CERT_COMMON_NAME_INVALID
Unable to verify that this server is indeed cloud.martin-abadie.fr, because its security certificate is from domain martin-abadie.fr.

My domain is:
martin-abadie.fr

I ran this command:
sudo /opt/letsencrypt/letsencrypt-auto --apache -d cloud.martin-abadie.fr
And it finish with success

My operating system is (include version):
Linux raspberrypi 4.4.38-v7+ #938 SMP Thu Dec 15 15:22:21 GMT 2016 armv7l GNU/Linux

Please, apologies my bad english, and thank you for spend time to read my post :slight_smile:


#2

In your apache config you are using the certificate for martin-abadie.fr in your cinfigutarion for the cloud.martin-abadie.fr domain.


#3

Thank you for your answer!

In sites-available directory I’ve got a cloud.https file with this content :

NameVirtualHost *:443 <VirtualHost *:443> ServerAdmin service.owncloud@gmail.com ServerName cloud.martin-abadie.fr DocumentRoot /var/www/owncloud/ SSLEngine On SSLCertificateFile /etc/letsencrypt/live/cloud.martin-abadie.fr/fullcha$ SSLCertificateKeyFile /etc/letsencrypt/live/cloud.martin-abadie.fr/priv$ </VirtualHost>

And I need to keep a certificate on my domain martin-abadie.fr


#4

I solved my problem by removing all .conf files and .https files and re-config by default 000-default.conf and default-ssl.conf.
Then, I create a site.conf file which contains my domain declaration, then cloud.conf which contains the sub-domain declaration.
Finally I ran Letsencrypt certification, which ends with success.

Thank you for watching my post, and for trying to help me! I hope it will help those who are in my case :slight_smile:


#5

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.