Standard force http to https isn't working


#1

I’ve tried several different methods to forcing to https and have zero luck doing so:


I thought that it was something to do with the originally generated certificate, so I tried redoing it and ended up with this problem:

Even though my domain IS on the internet:

http://freezepeach.xyz
https://freezepeach.xyz compare, and of course testing becomes a bear once the browser locks on that https works it ignores typing http manually, though just typing or linking the domain as it is is what people are doing, giving them a broken site.

so then:



Well of course you can’t connect to it, installer, that’s the problem.

What am I doing wrong? What should I be troubleshooting to fix it?


#2

You requested a certificate for www.freezepeach.xyz without having a corresponding entry in DNS. Either do not request www.freezepeach.xyz or put www.freezepeach.xyz in DNS.


#3

Thanks for the clarification.

Okay, so put a CNAME entry where my DNS stuff is handled, I’ve done that and it allows it to progress.

I check secure and try to reinstall and it tells me “unable to finalize checkpoint - adding title”


Which makes either http://freezepeach.xyz or www.freezepeach.xyz still unable to redirect to https without manually typing it in


#4

@HopeStillFlies, that’s an unfamiliar problem to me. It looks like it might be related to this issue:

Do you have a GitHub account that you could use to participate in that discussion and describe your situation?

My intuition is that it might have something to do with a problem that the client has in changing Apache configurations twice in two slightly different ways, but I’m not certain of that.


#5

I do have one, should I post my config files there? I went ahead and threw them on pastebin.

000-default.conf : http://pastebin.com/PyE432xm
000-default-le-ssl.conf : http://pastebin.com/B3rXFp2S

Of course I’ve deleted and added so many things while trying to troubleshoot this I may be lacking at this point.


#6

Yes, maybe you could try posting in that GitHub issue as well and see if anyone can help out. I think you’ve found a full-fledged client bug.