ssl.SSLEOFError: EOF occurred in violation of protocol (_ssl.c:1131)

I'm running on Ubuntu 20.04.4 LTS x86_64(Py3.7.9)
An unexpected error occurred:ssl.SSLEOFError: EOF occurred in violation of protocol (_ssl.c:1131)

When I run curl -i acme-v02.api.letsencrypt.org I get a (56) error (connection interrupted).

That URL does not support http. What does it show for:

curl -I https://acme-v02.api.letsencrypt.org
2 Likes

HTTP/2 200
server: nginx
date: Mon, 02 May 2022 16:13:39 GMT
content-type: text/html
content-length: 1651
last-modified: Wed, 05 Jan 2022 17:50:55 GMT
etag: "61d5da7f-673"
x-frame-options: DENY
strict-transport-security: max-age=604800

So it works.

1 Like

@huskyy8y8 Would you please answer the form questions as best you can?

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. crt.sh | example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is:

I ran this command:

It produced this output:

My web server is (include version):

The operating system my web server runs on is (include version):

My hosting provider, if applicable, is:

I can login to a root shell on my machine (yes or no, or I don't know):

I'm using a control panel to manage my site (no, or provide the name and version of the control panel):

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you're using Certbot):

2 Likes