EOF occurred in violation of protocol (_ssl.c:1131)

Hi all!
I'm running certbot on a recent CentOS 8 system (first installation feb '21).
Initially, the certificate was correctly issued. No renewal ever worked though. I get this error:

An unexpected error occurred:
requests.exceptions.SSLError: HTTPSConnectionPool(host='acme-v02.api.letsencrypt.org', port=443): Max retries exceeded with url: /directory (Caused by SSLError(SSLEOFError(8, 'EOF occurred in violation of protocol (_ssl.c:1131)')))

I updated the whole system, reinstallted snapd and certbot and reinstalled all Perl components with no luck. I still get that error.

When I run # curl -i acme-v02.api.letsencrypt.org I get a (56) error (connection interrupted).

I googled for a solution in the last two days. There is not much for the "_ssl.c:1131" error. I checked one thread on this forum but looks like the solution provided isn't working for me.

It looks like my public IP address is banned, could it be possible?

Thank you in advance.

1 Like

Hi @mnadalin, welcome to the LE community forum :slight_smile:

Yes, that seems highly likely from the messages shown.
Someone @lestaff can verify this for you later today.

In the meantime, is this public IP new to you?
Please show the public IP(s) with:
curl -4 ifconfig.co
curl -6 ifconfig.co

Can you connect securely from your server via curl to any other sites on the Internet?
curl -Iv https://google.com/

1 Like

Hello @rg305,
Thank you for your answer.

I can connect securely to https://google.com with the command provided.

I do have a public IPv4 address but I don't have an active IPv6 address. Well, it is present on the VPS but I'm not currently using it.
Is it safe/ok to paste the IPv4 address on this public forum or should I send it to you via private message?


Yes, @mnadalin, public IPs are always public.

1 Like

The public address is

1 Like

Then we wait for LE staff to review the IP.

1 Like

While you're waiting for LE to review, you may want to look at this thread which is probably describing the problem you're running into:


Sorry for the trouble; that IP is unblocked now. Thanks for your patience.


Thank you!

Everything is fine now :+1:


Although I am sorry to hear about your trouble...
This is not the right forum to talk about failed access to:

1 Like

And what does that specific error have to do with this forum?

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.