SSL not working for www domain on Dreamhost


#1

I added certificates to two domains I have with Dreamhost. One works on both www and non-www. The other domain does not work with www. How do I add a SAN to a cert issued via Dreamhost? Any help is greatly appreciated!


#2

Have you tried to contact Dreamhost? If you obtained the certificate from them, it may depend on the configuration of the domain on their side (I remember they have an option to enable www, non-www or both).


#3

Thanks for your reply! Yes, I have a support ticket in with Dreamhost. When I installed the certificate, Cloudflare was enabled on my site. I wonder if this has something to do with both www and non-www not being listed as DNS names.


#4

I have 5 domains that has Let’s Encrypt certificates on Dreamhost, but for all of those I have instructed Dreamhost to remove www.

If you allow both www and non-www then it is viewed as duplicate content by the great Google, so I would recommend choosing one of them.

Not sure if that is the issue, though.

Have you tried to view the certificate details on the manage domains page?

There could be error messages if something is wrong.


#5

Thanks!

Yes, I have non-www forwarding to www. I’ve viewed the details on the domains page and everything looks fine. It’s especially weird because the other cert I added at the same time to another DH domain works fine.


#6

Hello,
I noticed you mentioned that you have a site with CloudFlaire, in order for CloudlFlare to work with SSL you’d need to upgrade to the 9.99 option. I have included a wiki article from DreamHost here for you http://wiki.dreamhost.com/CloudFlare_with_SSL

MariT


#7

Thank you!

I think I made a mistake of not researching implications of CloudFlare before I added a free Let’s Encrypt certificate. The free CloudFlare was enabled on my site when I added the certificate. I disabled CloudFlare when I learned about this, but I wonder if I’m now running into problems as a result. I also deleted my initial certificate when CloudFlare was enabled, and got a new one after I disabled CloudFlare, but I’m wondering if this helped in any way. In fact, maybe it even caused more problems! I guess I need to wait for DH to get to my Support Ticket.


#8

I changed the hardcoded images to use https but it still didn’t working, then i realised the were some other hardcoded images in the themes css files so i modified them & the ssl now works & i get the padlock sign show.

but this now presents me with a new problem, the magento has become very slow since ssl was enabled on the site. if you coud pls suggest something that i can do to make the site go faster i would very much appreciate it. thanking you JasonSmith :slight_smile:
https://akinator.ooo/ https://xender.vip/ https://kik.onl/


#9

I am using ssl on my website frackman. Some of my images not redirect to https. How can i fix this problem? please help me. Thank you.


#10

Hi @frackman

I don’t get mixed content warnings. If you see images not redirected: Then change your code - http -> https.