SSL is not applied on my site after I successfully enabled HTTPS

I have followed the Certbot instruction for my ubuntu server, and the steps successfully finished as expected. However, after I tried to access the website using HTTPS it did not work, but it is working using HTTP as usual. Any suggestion?

My domain is: fetlee.allenatech.com

I ran this command: sudo certbot --nginx

It produced this output: Which names would you like to activate HTTPS for?

My web server is: nginx/1.14.0 (Ubuntu)

The operating system my web server runs on is: Ubuntu 18.04.4 LTS (Bionic)

I can login to a root shell on my machine: Yes

The version of my client is (e.g. output of ‘certbot --version’ or certbot-auto --version if you’re using Certbot): certbot 0.31.0

1 Like

You could try answering the questions you deleted when you started this topic. Without that information, none of us has any basis to guess what might be happening.

1 Like

Thank you for the feedback, I have edited the post.

1 Like

Hi @Tesfay

there is a check of your domain, ~~5,5 hours old - https://check-your-website.server-daten.de/?q=fetlee.allenatech.com

You have created two certificates, so that part has worked.

Issuer not before not after Domain names LE-Duplicate next LE
Let’s Encrypt Authority X3 2020-02-14 2020-05-14 fetlee.allenatech.com - 1 entries duplicate nr. 2
Let’s Encrypt Authority X3 2020-02-14 2020-05-14 fetlee.allenatech.com - 1 entries duplicate nr. 1

But your https doesn’t work.

Domainname Http-Status redirect Sec. G
http://fetlee.allenatech.com/ 196.190.41.210 301 https://fetlee.allenatech.com/
Html is minified: 107,78 % 0.280 A
https://fetlee.allenatech.com/ 196.190.41.210 -2 1.454 V
ConnectFailure - Unable to connect to the remote server

Works https internal?

curl https://fetlee.allenatech.com/

from that server?

What says

nginx -T
certbot certificates
1 Like

Hi @JuergenAuer,

Here are the commands with their results:

Command 1: curl https://fetlee.allenatech.com/
Result 1: curl: (7) Failed to connect to fetlee.allenatech.com port 443: Connection refused

Command 2: certbot certificates
Result 2:
Saving debug log to /var/log/letsencrypt/letsencrypt.log


Found the following certs:
Certificate Name: fetlee.allenatech.com
Domains: fetlee.allenatech.com
Expiry Date: 2020-05-14 07:48:27+00:00 (VALID: 89 days)
Certificate Path: /etc/letsencrypt/live/fetlee.allenatech.com/fullchain.pem
Private Key Path: /etc/letsencrypt/live/fetlee.allenatech.com/privkey.pem


Moreover, now, both HTTP and HTTPS are not working.

1 Like

Solved! The issue was docker related. :slight_smile:

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.