SSL Installed but not valid

My domain is:

I ran this command: I didn’t run anything??

It produced this output:

My web server is (include version): I really have no idea I use Wordpress

The operating system my web server runs on is (include version):

My hosting provider, if applicable, is: GoDaddy

I can login to a root shell on my machine (yes or no, or I don’t know): I don’t know

I’m using a control panel to manage my site (no, or provide the name and version of the control panel): CPanel

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you’re using Certbot): I don’t know

I’m using the ssl certificates from zero SSL

On my home page when I click the info icon beside my URL it shows that the certificate is valid but still shows that the connection to the site is not secure.

As well as this only my homepage is redirecting to https: and on any of my other pages there is no certificate at all and it doesn’t redirect to https:. The cert only works on my homepage.

I have changed it to https: in my wordpress settings and also added the following lines into my .htaccess file.

RewriteEngine On
RewriteCond %{HTTPS} off
RewriteRule ^(.*)$ https://%{HTTP_HOST}%{REQUEST_URI} [L,R=301]

This happened when I had a certificate active, I re-installed a new one and the issue was still there.

Thanks for the help in advance

Actually I was wrong… the certificate is showing as valid for all pages it is just the issue of the connection to the website not being secure

Hi @stephaniealbert

checking your domain you see the problem -

There is mixed content:

The stylesheet

is loaded via https. But there are a lot ouf url("...") links with http.

Change these to https.

Your certificate is new and valid:
expires in 89 days, - 2 entries
1 Like

Thanks so much for this advice, but how exactly would I go about doing this?

Also shouldn’t the code snippet in the .htaccess file do this for me?

Edit your css file post-53.css, change http to https.

A redirect comes too late. Then the browser must first load the http link to see the redirect.

How do I access this file? I can’t find post-53.css in my editor in WordPress

Please check the file name. elementor is a WordPress Page builder.

Check the image urls, then you should know where you can change these urls.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.