SSL files inaccessible NodeJS

hmm

It used to work yesterday, I was super happy everything finally worked.
Then I restarted windows, and I think that's when windows decided to f me up and apply security after reload.

I tried everything, I can't figure it out.

I'm getting insane.

If someone want to help me in real time Auracle#1001 discord

1 Like

I can't say for certain; as I'm not familiar with most of your setup.
But I think it might be a permissions issue.
Where you may need to either run your node.js as admin or explicitly provide it access to the files needed.
Note: The file shown is usually just a symbolic link and you may need to provide access to the link and also to the destination folder.

And also: Sorry but "real-time" help would not benefit any future readers of this forum.

1 Like

For the real time : I could post the solution once I find it. That's what I did on another post.

Oh and I know it's a permission issue, and if you check script it's a direct link to the .pem files.
Also even in admin for some reason it's not working...

1 Like

image

Please show the complete DOS output of:
dir C:\Certbot\live\auracle.tech\

1 Like

jp

Note : A direct link with Xampp to these 0 files was working. Also, before windows restarted, it was working with NodeJS. I thought I fixed this issue by reinstalling Certbot but that's probably because I didn't restart the computer so permissions were not setup or something.

1 Like

I see links.
I asked for DOS, you gave me PS.

I understand "it was working".
I also gave you my best advice.

The persmissions problem is NOT with certbot - it is with you node.js.

1 Like

Aight I'll need to have application start in admin I figured out issue...

No choice but to use admin at this point. What a pain...

1 Like

So you "figured out" what I first said?:

1 Like

Your "solution" in post #7 is merely a repeat of post #2
But if you insist on "taking the credit" - have fun with that.
I don't get paid any more or any less either way - I volunteer my time to those that need help.
Although I am glad you solved your problem, I'm just a bit sorry that I seem to have wasted my time trying to help someone that obviously doesn't ever accept being helped.

1 Like