SSL expired need help renewing


#1

I thought I had the cert renewed, but evidently it didn’t work and now the site is down. I’m running Ubuntu 14.04 on DigitalOcean droplet. Anybody have any advice on how to resolve this?


#2

Can you share your domain name and what commands you ran?


#3

Yes, the domain is filepile.us. I’ve tried several commands, a couple I’ve tried is ‘sudo letsencrypt renew’, and ‘letsencrypt-auto renew’, and I tried updating the certbot with ‘certbot renew --dry-run’. Received “Command not found”.


#4

So, do you remember how you installed Certbot and how you originally ran it when you first got the certificate? For example, did you manually download certbot-auto into a particular directory, or did you use an operating system package?


#5

I apologize for my ignorance, for this is my first project of the sort. However, I did follow this tutorial: https://www.digitalocean.com/community/tutorials/how-to-secure-nginx-with-let-s-encrypt-on-ubuntu-14-04


#6

According to that recipe, certbot-auto would be in /usr/local/sbin, which is probably in root’s PATH but not in a regular user’s PATH. Thus, running just certbot-auto as a regular user won’t find it, wihle running it as root would find it.

You can also just specify the explicit path, like

/usr/local/sbin/certbot-auto renew


#7

That seems to be close to a resolution. It ran a bunch of stuff, then said

"Certbot has problem setting up the virtual environment.

Based on your pip output, the problem can likely be fixed by
increasing the available memory.

Consult https://certbot.eff.org/docs/install.html#problems-with-python-virtual-environment
for possible solutions."

Think updating pip would solve this?


#8

Maybe try sudo /usr/local/sbin/certbot-auto renew first, in case it’s just a file permission problem.


#9

Received the same message again.


#10

Could you run free to see how much memory you have?


#11

Free shows 101040. Used is 399392


#12

@bmw, could you opine on whether the low-memory diagnosis is likely right or a false alarm?


#13

I was able to delete a bunch of stuff to where I have 50% free space and using 11% ram. I ran /usr/local/sbin/certbot-auto renew and still received the same message about pip and lack of memory.

Running ‘free’ says: 124632 free

Edit: I attempted to update pip and it wouldn’t let me do that either.


#14

Yes the low memory diagnosis seems correct. 124632 is 121.7MB and the link output by certbot-auto talks about people having issues on a VPS with less than 512MB. This large memory usage is due to certbot-auto trying to install some of our Python dependencies which have to compile against C libraries. I encourage you to follow the linked advice of creating a swapfile and trying again.


#15

Resizing the droplet, and using schoen’s command fixed it! Thank you both so much!


#16

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.