Certbot is Borken, Can't renew, too many errors!


#1

Note that I have already succesfully used this installation to obtain and renew certs but when I went in and ran the command ./certbot-auto renew or /certbot-auto it breaks with lots of errors.

Here is the dump file of the console

Here is some sidenotes:

My installed version for python is 2.6.6
OS: Centos 6

Update:

I have updated python version 2.7 but still having the problem

Note that I have upgraded PIP version to 9…0.1 but it still shows this warning about pip.


#2

can anyone give me a direction?


#3

hi sisir

I believe there is a log file which you can review and see if anything pops

Are you running as root as this has caused a few issues in the past


#4

I am running it as root.

btw, i have found this issue, there is an workaround given but I don’t know how to do it https://github.com/certbot/certbot/issues/2902


#5

I don’t think that issue is related - it seems to be about urllib3, while your error happens during cffi compilation.

Any chance you’re doing this on a low-memory system, or that there’s very little free memory on your server (free -h to check)? You might be running into this issue:


(192MB being just a sample of too little RAM, not sure what the exact memory usage would be.)


#6

the out of free -h is

             total       used       free     shared    buffers     cached
Mem:          1.8G       1.6G       221M       412K       155M       633M
-/+ buffers/cache:       858M       1.0G
Swap:         511M        34M       477M

#7

That looks fine. Was there anything else that changed on that server between the time certbot worked and when you first encountered that error? Any chance you installed a custom openssl version (i.e. not the one you get through the default repo via yum)?


#8

I ran the command second time and this time the free memory came around 144M. So, i think it may be the memory issue after all. I will kill some httpd processes and try to reran the command.


#9

According to your log, you are missing vital header files:

[...]
    In file included from /usr/include/python2.7/Python.h:8,
                 from c/_cffi_backend.c:2:
/usr/include/python2.7/pyconfig.h:1:27: error: bits/wordsize.h: No such file or directory
/usr/include/python2.7/pyconfig.h:8:2: error: #error "Unknown word size"
In file included from /usr/lib/gcc/x86_64-redhat-linux/4.4.7/include/syslimits.h:7,
                 from /usr/lib/gcc/x86_64-redhat-linux/4.4.7/include/limits.h:11,
                 from /usr/include/python2.7/Python.h:19,
                 from c/_cffi_backend.c:2:
/usr/lib/gcc/x86_64-redhat-linux/4.4.7/include/limits.h:122:61: error: limits.h: No such file or directory
[...]

It looks like you are missing the glibc-headers package (I don’t use Centos, but a quick google search turned up that name…). Try installing that and try again!


#10

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.