Certbot-auto renew triggers update to 1.2, but won't finish

My domain is:
fntpost.com

I ran this command:
sudo certbot-auto renew

It produced this output:
Upgrading certbot-auto 1.0.0 to 1.2.0…
Replacing certbot-auto…
Bootstrapping dependencies for Legacy RedHat-based OSes that will use Python3… (you can skip this with --no-bootstrap)
yum is hashed (/usr/bin/yum)
To use Certbot on this operating system, packages from the SCL repository need to be installed.
Enable the SCL repository and try running Certbot again.

My web server is (include version):
Apache/2.2.15 (Unix)

The operating system my web server runs on is (include version):
RHEL6 (Red Hat Enterprise Linux Server release 6.10 Santiago)

I can login to a root shell on my machine (yes or no, or I don’t know): Yes

I’m using a control panel to manage my site (no, or provide the name and version of the control panel): No

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you’re using Certbot): I get the same messages as above when trying to check version, but I asssume from the first message that certbot is now v1.2
$ sudo ./certbot-auto --version
Bootstrapping dependencies for Legacy RedHat-based OSes that will use Python3… (you can skip this with --no-bootstrap)
yum is hashed (/usr/bin/yum)
To use Certbot on this operating system, packages from the SCL repository need to be installed.
Enable the SCL repository and try running Certbot again.

Things I tried…
Checked that scl-utils were installed…
$ sudo yum install scl-utils
Loaded plugins: replace, rhnplugin, security
This system is receiving updates from RHN Classic or RHN Satellite.
Setting up Install Process
Package scl-utils-20120927-29.el6_9.x86_64 already installed and latest version
Nothing to do

Saw a thread about checking the output of this statement should be 0, but it’s not.
$ yum list *virtualenv
Loaded plugins: replace, rhnplugin, security
Note Red Hat Network repositories are not listed below. You must run this command as root to access RHN repositories.
Installed Packages
python-virtualenv.noarch 12.0.7-1.el6 @rs-epel

So I checked that EPEL is enabled.
My /etc/yum.repos.d/ directory has these files
-rw-r–r-- 1 root root 528 Dec 8 2016 dell-system-update.repo
-rw-r–r-- 1 root root 194 Jun 16 2015 rackspace-cloud-monitoring-stable.repo
-rw-r–r-- 1 root root 529 Nov 21 13:30 rhel-source.repo
-rw-r–r-- 1 root root 696 May 20 2015 rs-epel.repo
-rw-r–r-- 1 root root 758 May 20 2015 rs-epel-testing.repo

So I looked inside rs-epel.repo, and see that there is enabled=1 in the first section…
[rs-epel]
name=Extra Packages for Enterprise Linux 6 - $basearch
baseurl=https://mirror.rackspace.com/epel/6/$basearch
failovermethod=priority
enabled=1
gpgcheck=1
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-EPEL-6
exclude=awstats

[rs-epel-debuginfo]
name=Extra Packages for Enterprise Linux 6 - $basearch - Debug
baseurl=https://mirror.rackspace.com/epel/6/$basearch/debug
failovermethod=priority
enabled=0
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-EPEL-6
gpgcheck=1

[rs-epel-source]
name=Extra Packages for Enterprise Linux 6 - $basearch - Source
baseurl=https://mirror.rackspace.com/epel/6/SRPMS
failovermethod=priority
enabled=0
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-EPEL-6
gpgcheck=1

My certificate expires in 10 days. What do I need to do to renew it?

1 Like

Hi,

The message indicated that certbot needs scl to be enabled.

Please try to run yum repolist all to list all available repository.
Please also run subscription-manager repos --list to check if you have any repo looked similiar to rhscl, rhel-x86_64-server-6-rhscl-1, rhel-server-rhscl-6-rpms.

Thank you

1 Like

This is the result of those two commands:
$ yum repolist all
Loaded plugins: replace, rhnplugin, security
Note Red Hat Network repositories are not listed below. You must run this command as root to access RHN repositories.
repo id repo name status
dell-system-update_dependent dell-system-update_dependent enabled: 61
dell-system-update_independent dell-system-update_independent enabled: 681
rackspace Rackspace Monitoring enabled: 1
rhel-source Red Hat Enterprise Linux 6Server - x86_64 - Source disabled
rhel-source-beta Red Hat Enterprise Linux 6Server Beta - x86_64 - Source disabled
rs-epel Extra Packages for Enterprise Linux 6 - x86_64 enabled: 12,582+1
rs-epel-debuginfo Extra Packages for Enterprise Linux 6 - x86_64 - Debug disabled
rs-epel-source Extra Packages for Enterprise Linux 6 - x86_64 - Source disabled
rs-epel-testing Extra Packages for Enterprise Linux 6 - Testing - x86_64 disabled
rs-epel-testing-debuginfo Extra Packages for Enterprise Linux 6 - Testing - x86_64 - Debug disabled
rs-epel-testing-source Extra Packages for Enterprise Linux 6 - Testing - x86_64 - Source disabled
repolist: 13,325

$ subscription-manager repos --list
-bash: subscription-manager: command not found

Can you try to run this as root again?

Thank you

$ sudo yum repolist all
Loaded plugins: replace, rhnplugin, security
This system is receiving updates from RHN Classic or RHN Satellite.
repo id repo name status
dell-system-update_dependent dell-system-update_dependent enabled: 61
dell-system-update_independent dell-system-update_independent enabled: 681
rackspace Rackspace Monitoring enabled: 1
rackspace-rhel-x86_64-server-6-common Rackspace - RHEL (v. 6 for 64-bit x86_64) - Common enabled: 185
rackspace-rhel-x86_64-server-6-ius Rackspace - RHEL (v. 6 for 64-bit x86_64) - IUS enabled: 7,027
rhel-source Red Hat Enterprise Linux 6Server - x86_64 - Source disabled
rhel-source-beta Red Hat Enterprise Linux 6Server Beta - x86_64 - Source disabled
rhel-x86_64-server-6 Red Hat Enterprise Linux Server (v. 6 for 64-bit x86_64) enabled: 21,009
rhel-x86_64-server-optional-6 RHEL Server Optional (v. 6 64-bit x86_64) enabled: 12,144
rhn-tools-rhel-x86_64-server-6 RHN Tools for RHEL (v. 6 for 64-bit x86_64) enabled: 233
rs-epel Extra Packages for Enterprise Linux 6 - x86_64 enabled: 12,582+1
rs-epel-debuginfo Extra Packages for Enterprise Linux 6 - x86_64 - Debug disabled
rs-epel-source Extra Packages for Enterprise Linux 6 - x86_64 - Source disabled
rs-epel-testing Extra Packages for Enterprise Linux 6 - Testing - x86_64 disabled
rs-epel-testing-debuginfo Extra Packages for Enterprise Linux 6 - Testing - x86_64 - Debug disabled
rs-epel-testing-source Extra Packages for Enterprise Linux 6 - Testing - x86_64 - Source disabled
repolist: 53,923

Hi,

Is your system registered with RHN classic?

If so, can you try the steps in RHEL doc Section 2.1.1. Using RHN Classic?

As of now, you don’t seem to have SCL enabled. Please try the above step and if success, try to enable that repo according to https://access.redhat.com/documentation/en-us/red_hat_software_collections/1/html/1.0_release_notes/chap-Installation_and_Usage#sect-Installation_and_Usage-Install.

Thank you

Server is with Rackspace, they have the RHN classic account info so I’ve sent them a ticket about the repo.

I will report back.

1 Like

So anyone else using Rackspace might find this informational. Their policy is they don’t install SCL by default.

RHSCL is a “Reasonable Endeavor” technology, and as such does not carry the same level of support as other operating system items.

So I basically had to agree they didn’t have any responsibility or support for this after the install.

But once I got them to install it, I was able to update certbot and get my SSL renewed. Thank you!

2 Likes

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.