Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. |, so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is:

I ran this command: I try to open my website ( on chrome, firefox, internet explorer but getting SSL_ERROR_NO_CYPHER_OVERLAP error.

It produced this output: SSL_ERROR_NO_CYPHER_OVERLAP ( even though I have enabled Let's Encrypt SSL on my website and ssl certicate is valid till 9. March.2023)

My web server is (include version): Shared IP Address

The operating system my web server runs on is (include version): linux 4.19.150-76.ELK.el7.x86_64

My hosting provider, if applicable, is: Bluehost

I can login to a root shell on my machine (yes or no, or I don't know): yes on my machine but not on webserver maschine

I'm using a control panel to manage my site (no, or provide the name and version of the control panel): Yes and cPanel Version is 102.0 (build 26)

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you're using Certbot): unfortunately I do not know what it is.

please help me to solve above mentioned problem on my website.

Please inform me if you need any other information.

Thank you very much !!

1 Like

Hi @saurabh162, and welcome to the LE community forum :slight_smile:

SSL Server Test: (Powered by Qualys SSL Labs)

This is very interesting:

curl -Ii
HTTP/1.1 301 Moved Permanently
Date: Mon, 12 Dec 2022 15:58:47 GMT
Content-Type: text/html; charset=iso-8859-1
Connection: keep-alive
CF-Cache-Status: MISS
Server: cloudflare
CF-RAY: 7787a9dbfd13dae9-MIA

How is CloudFlare involved?


There seems to be some fundamental problem within the server.
As shown by some of the other names on the cert:

500 Internal Server Error (
500 Internal Server Error (

And the other names resolve to another IP address.
So, there is some kind of transparent proxy in front of the base domain.
Something else can explain why CloudFlare is seen in that path.


@rg305 thank you very much for your reply, and you are right. After reading my plan on Bluehost, I come to know that CloudFlare proxy server is enabled by default and I cannot disable it.
As it is also mentioned in following link.

Due to which my website opens by giving instead of only "".

Additionally, if I am right, Bluehost has mentioned in above link that I can make "" by doing some configuration changes.

Can you please inform me

  1. whether it is possible to make "" work ?
  2. If yes, then how ?

Thank you very much again for your time and help !!

1 Like

I don't use BlueHost, nor am I familiar with their CloudFlare use.
I would recommend that you first address the "500 Internal Server Error".


@rg305 thank you !! Honestly I do not know how to debug this problem. I think I need to contact Bluehost team for this problem .

Thank you and have a nice day !!


Have you tried rebooting the server?
[if you can do that, I would - nothing is working at the moment]


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.