SSL certificate issued but not working


#1

I got the message that the certificate was activated for all versions (with and without www.) but now it says site is not secure when I open it on a browser. The site is 2weeksinsrilanka.com
If it takes time for the certificate to fully activate how long would it be? Please help.


#2

Hi @anticleon,

The certificate is working just fine on https://www.2weeksinsrilanka.com/. However, http://www.2weeksinsrilanka.com/ (note http:// rather than https://) still works and does not redirect to the HTTPS version. Therefore, only people who specifically visit the HTTPS version of the site will have a secure connection.

This is not a problem with the certificate or its installation at all. Instead, you need to create a redirection so that the HTTP version of the site automatically redirects visitors to the HTTPS version. The best way to do this depends on your server software and hosting environment.


#3

Please show the exact URL that says is not secure.
(or a screenshot that contains the error and the URL)

And to add to what @schoen noted.
There is a permanent redirection to the www:
from
http://2weeksinsrilanka.com/
to
http://www.2weeksinsrilanka.com/
and from
https://2weeksinsrilanka.com/
to
https://www.2weeksinsrilanka.com/

But no redirection from http to https.


#4

schoen and rg305
Thanks for your replies. I can’t find the htaccess file in the cpanel. I cheked show hidden files and selected the root for option. but that file is missing. i know this could be a dumb question but what could be the reason please? I am new to this whole thing :slight_smile:
Thanks a lot guys. Looks like it was my cache that was showing me the same thing when I was refreshing. Opened a new tab and it was there. All done. Thanks a lot. You saved my day.


#5

I’m still not sure what the exact problem is.
Redirection would only force everyone to the secure site.
If you manually type in the secure URL and it is giving you a “not secure” message, we need to see it.


#6

It was alright when I typed the https version. only the other versions were not secure.
Now it’s all ok. I added a redirect in the .htaccess and now it works fine. Thank you for helping.


#7

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.