[solved] Unable to access sites certified by Lets Encrypt .Windows 7

I am trying to access sites which have been certified by Lets Encrypt but only get the:- There is a problem with this websites security certificate.

other site work perfectly well and the problem sites work OK on my Win 10 machine.

I am using windows 7 professional with service pack 1 on the problem machine.

Some of the offending sites include your own - letsencrypt.org and www.beiley.com.

as I said it seems the problem only occurs on windows 7 and I found the similar problem mentioned on another forum:-1:https://www.sevenforums.com/browsers-mail/409860-certificate-error-websites-lets-encrypt-certificate.html
but without a solutions.

I am very green when it comes to this type of problem so would appreciate it if there is a solution to the problem it could be explained in lay mans terms.

Hope someone can help

Hi @wartburg,

Do you receive the same error using IE, Chrome and Firefox (IE and Chrome use the Windows Trusted Root CA directory and Firefox uses its own directory)?. An screenshot with the error could help.

Just for the records, https://letsencrypt.org doesn't use a certificate issued by Let's Encrypt.

Are you using a proxy?. Do you have some kind of antivirus?. Some of them act as a proxy performing some kind of man in the middle intercepting these connections. I you are using one... disable it completely and try again.

Time to sleep here but if you can answer the questions some community's member could follow the issue and try to help you to solve it.


1 Like

When was the last time you ran Windows Updates?

1 Like

It is issued by IdenTrust, though. If the root is fried, that would break both.

me am using Lets Encrypt in all my site even like my main site but its working fine even in window 7

[Edit: link removed by moderator]

Root CA issuers are different, both belong to IdenTrust but are different (IdenTrust Commercial Root CA 1 vs DST Root CA X3). Even if no Root CA certificate for IdenTrust was there, Let's Encrypt certificates could still work if the ISRG Root CA Certificate is installed properly :wink:.

Many thanks for your replies. to answer some questions

Tried access with Firefox and find no problem - IE still has problem

Windows up dates are all up to date - last one loaded yesterday

Using Avast but removed it yesterday and problem still with IE

Also turned off firewall - same problem

After further investigation I was able to access the Certification path and find that the problem sites
DST Root CAX3 - IdenTrustCommercial Root Ca 1 - TrustID Server CA A52 - letsencrypt .org
& DST Root CAX3 - Let’s Encrypt Authority X3 - www.beiley.com

When I highlight the DST Root CAX3 the certificate status box says - The CA Root certificate is not trusted because it is not in the Trusted Root Certificate Authorities store.

This would obviously seen to be the problem as when I check -Trusted Root Certification Authorities - certificates - I cannot find DST Root CAX3 mentioned.

My question now is how do I get DST Root CAX3 registered as a trusted Certificate - is it possible to copy the file from my Win 10 Machine to Win 7 machine - will it work or do I need a Win7 version.

I exported the file from win 10 and installed in Win 7 Now all seems to be ok again in IE.

Many thanks to all those who helped

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.