Everywebsite that uses lets encrypt is broken form me

Every website that uses lets encrypt is broken form me on brave and chrome (using the latest firefox to post this), every single site gives me "Your connection is not private

Attackers might be trying to steal your information from ..."

What on earth is going on? it is making the web unusable. I am using windows 7 and latest chrome but cannot update brave as it keeps failing probably due to certificates. This started happening a couple of days ago so related to - DST Root CA X3 Expiration (September 2021) - Let's Encrypt ?

Likely your Win7 has not updated its' root store for quite some time.
Does it get Windows Updated?
[I know MS stopped providing updates but they never stopped providing trusted root store updates that way]
If you can't WU or that fails (may require a reboot to be sure), you can always insert the missing roots manually.
You can get them at: Chain of Trust - Let's Encrypt (letsencrypt.org)


@GMM Do you get that same error when browsing this site with Chrome?


Trying this will give a further clue as to what exactly is wrong. There are two valid certificate chains. This link uses the 'short chain'. The community.letsencrypt.org site uses the 'long chain' but you already said this site was a problem for you except with Firefox.


Yes- Your connection is not private

Attackers might be trying to steal your information from acme-v02.api.letsencrypt.org (for example, passwords, messages, or credit cards). [Learn more](

https://community.letsencrypt.org/ is worse on chrome it is just a blank page, if I view page source it is the community so maybe the style sheets are not loading.

Guess it is a switch to firefox and import everything as searching is impossible in chrome and brave as every second website gives the error.


It looks like Rudy's diagnosis is correct - the problem is most likely that you are missing the ISRG Root X1 certificate. It has been around for a long time so not sure why you would not have it.

Looking around I see you were on a related thread. The person here found a solution. This should work for you too:


Yes that fixed it, thanks.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.