[SOLVED] SSL Certificate renewal success, but validity unchanged


#1

Hi,

I’m trying, and it seems I’ve succeeded in renewing/generating the validity of my existing SSLs for my domain by using the instructions on https://gethttpsforfree.com

I’ve been using this tool to update the SSL certificates via a CSR for a while now, and although the process goes through smooth this time as well, when I update the certificate on cPanel, I see that the validity date is still the same validity date as earlier.

Any clues as to how I can go about fixing this?

Cheers!

My domain is: zenparkin.com, and www.zenparkin.com

I ran this command: https://gethttpsforfree.com

It produced this output: “Congratulations! Let’s Encrypt has issued you a certificate for your domains! Below is the signed certificate you can use for your website.”

My web server is (include version): Apache 2.4.33

The operating system my web server runs on is (include version): linux

My hosting provider, if applicable, is: Inmotion Hosting

I can login to a root shell on my machine (yes or no, or I don’t know): Don’t know

I’m using a control panel to manage my site (no, or provide the name and version of the control panel): Yes, v 68.0.39


#2

Hi,

That means the certificate you pasted is not the newest obtained one. Did you use the same csr as last time? (If this is the case, is there a possibility that you clicked on “auto fill by key”?)

Thank you


#3

[SOLVED]

Thanks for your prompt response.

This might likely have been the problem. I poked around a bit more on the cPanel’s SSL/TLS section, and saw that I had a host of Certificates (CRT) defined with the old expiry date, so I added the new certificate in this section first, then went onto update the SSL for the respective domain(s) with the same certificate, and using Autofill by domain, and this time it did work as expected with an extended validity date.


#4

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.