[SOLVED] Site "loses" secure connection


#1

Hi. I have a weird problem. When I load my site ( https://rafaellaguna.uk ) the browser shows the green padlock, but once the page starts loading content, it becomes red, as untrusted. I have a NextCloud instace and everything shows ok there. I checked twice my certificate and ssllabs says it’s fine. Any clues?

Thanks in advance.


#2

hi @redwolf

have a look at the site here: https://www.whynopadlock.com/check.php

there is one form call to an unsecure website which may be causing your issues.

I haven’t had any issues on firefox but chrome is complaining

What browser are you using?

Nice logos and site btw :smiley:

Andrei


#3

Thank you! :smiley: I’m using Vivaldi (Chrome), and with that tool you provided it says:

Insecure call.
Found on line # 409 in file: rafaellaguna.uk/index.html
(Note: Chrome will show a security error for any secure page with an insecure call on the page)

Is it a simple form causing this? Unbelievable. It is solved now by simply using “https” even if the external call isn’t secure. Anyways, thanks so much for your fast reply.


#4

hi @redwolf

that’s why that padlock tool is so useful.

By the looks of things Chrome is being a bit more aggressive on the HTTPs lock requirements (requiring all images and links to be HTTPS) than other browsers

Glad you got it sorted and your site now has the green padlock on chrome for me as well :smiley:

Andrei


#5

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.