[Solved] Python error running letsencrypt-auto


#1

Hi,

Did a quick search and found nothing related.

I installed the letsencrypt client (had to to install virtualenv via pip, too). All I get when running letsencrypt-auto is:

zulu ~/letsencrypt :( #  ./letsencrypt-auto --agree-dev-preview --server https://acme-v01.api.letsencrypt.org/directory auth
Updating letsencrypt and virtual environment dependencies......
Running with virtualenv: /root/.local/share/letsencrypt/bin/letsencrypt --agree-dev-preview --server https://acme-v01.api.letsencrypt.org/directory auth
An unexpected error occurred.
PythonDialogErrorBeforeExecInChildProcess
Please see the logfile 'letsencrypt.log' for more details.

Letsencrypt.log shows:

zulu ~/letsencrypt :( # cat letsencrypt.log 
Traceback (most recent call last):
  File "/root/.local/share/letsencrypt/bin/letsencrypt", line 11, in <module>
    sys.exit(main())
  File "/root/.local/share/letsencrypt/lib/python2.7/site-packages/letsencrypt/cli.py", line 1092, in main
    setup_logging(args, _cli_log_handler, logfile='letsencrypt.log')
  File "/root/.local/share/letsencrypt/lib/python2.7/site-packages/letsencrypt/cli.py", line 1014, in setup_logging
    cli_handler = cli_handler_factory(args, level, fmt)
  File "/root/.local/share/letsencrypt/lib/python2.7/site-packages/letsencrypt/cli.py", line 1001, in _cli_log_handler
    handler = log.DialogHandler()
  File "/root/.local/share/letsencrypt/lib/python2.7/site-packages/letsencrypt/log.py", line 29, in __init__
    self.d = dialog.Dialog() if d is None else d
  File "/root/.local/share/letsencrypt/lib/python2.7/site-packages/dialog.py", line 1038, in __init__
    self.backend_version())
  File "/root/.local/share/letsencrypt/lib/python2.7/site-packages/dialog.py", line 1817, in backend_version
    use_persistent_args=False)
  File "/root/.local/share/letsencrypt/lib/python2.7/site-packages/dialog.py", line 1541, in _perform
    args_file)
  File "/root/.local/share/letsencrypt/lib/python2.7/site-packages/dialog.py", line 1502, in _handle_program_exit
    child_output_rfd)
  File "/root/.local/share/letsencrypt/lib/python2.7/site-packages/dialog.py", line 1466, in _wait_for_program_termination
    more precisely what happened."""))
PythonDialogErrorBeforeExecInChildProcess

I am on Arch x64.

I am at a loss as to where to start troubleshooting (no experience with Python at all).Is this a problem with my Python environment or something else?

Thanks,
Sakman


#2

Take a look at #1198. There was a user there that had the exact same problem and resolved it by updating all their packages.


#3

Thanks alot bmw. I solved the issue with that link.