[./letsencrypt-auto] chocked up on 'undefined symbol: EC_GFp_nistp224_method'


#1

Hi all,

Thanks for you beta invitation. I started with the letsencrypt-auto script, and it threw me an error looks like something wrong with OpenSSL. Could that be a problem with the virtualenv or python, or openssl(1.0.1k 8 Jan 2015)?

Thanks

qzhou

Debian Jessie, with latest updates.

$ ./letsencrypt-auto --agree-dev-preview --server       https://acme-v01.api.letsencrypt.org/directory auth 
    Updating letsencrypt and virtual environment dependencies......
    Running with virtualenv: sudo /home/username/.local/share/letsencrypt/bin/letsencrypt --agree-dev-preview --server https://acme-v01.api.letsencrypt.org/directory auth
    Traceback (most recent call last):
      File "/home/username/.local/share/letsencrypt/bin/letsencrypt", line 7, in <module>
        from letsencrypt.cli import main
      File "/home/username/.local/share/letsencrypt/lib/python2.7/site-packages/letsencrypt/cli.py", line 15, in <module>
        import OpenSSL
      File "/home/username/.local/share/letsencrypt/lib/python2.7/site-packages/OpenSSL/__init__.py", line 8, in <module>
        from OpenSSL import rand, crypto, SSL
      File "/home/username/.local/share/letsencrypt/lib/python2.7/site-packages/OpenSSL/rand.py", line 11, in <module>
        from OpenSSL._util import (
      File "/home/username/.local/share/letsencrypt/lib/python2.7/site-packages/OpenSSL/_util.py", line 6, in <module>
        from cryptography.hazmat.bindings.openssl.binding import Binding
      File "/home/username/.local/share/letsencrypt/lib/python2.7/site-packages/cryptography/hazmat/bindings/openssl/binding.py", line 13, in <module>
        from cryptography.hazmat.bindings._openssl import ffi, lib
    ImportError: /home/username/.local/share/letsencrypt/lib/python2.7/site-packages/cryptography/hazmat/bindings/_openssl.so: undefined symbol: EC_GFp_nistp224_method

#2

Exactly the same problem here, also on Debian Jessie with latest updates.

Regards
Crazy


#3

I tried to fix this by manually install the lets encrypt python package with my conda python.

Since then it works fine.

It looks like packages were installed to apt python, but ran by a conda python.


#4

I’m also getting this error. I have no idea what a “conda Python” is - the only thing I have installed is a python through apt (required through another apt-only dependency), and a python built from source through Linuxbrew, which I use as my default python (although I rarely use python for personal use). I’m getting this same error with the letsencrypt-auto and installng manually through virtualenv. The only thought I have is that possibly the letsencrypt-auto is installing to the apt Python and then using the linuxbrew python (which is only in PATH through my .bash_history), or vice versa.


#5

Update: Even ignoring my .bash_profile (which sets my PATH to the homebrew bin) makes no difference.


#6

Found a newer issue, moving here