[SOLVED] Cert Creation | WWW Prefix needed?

I need to have a cert for a domain without www.-suffix. Please see below, what I did and what I got. I am not running an own nameserver and my ISP is not providing deep subdomaining like sub.sub.domain.tld.
Can you advice?

certbot certonly --webroot -d sub.domain.tld --webroot-path /srv/http/vhosts/sub.domain.tld/

Requesting a certificate for sub.domain.tld

Certbot failed to authenticate some domains (authenticator: webroot). The Certificate Authority reported these problems:
  Domain: sub.domain.tld
  Type:   dns
  Detail: 130.xxx.xxx.xxx: Fetching http://www.sub.domain.tld/.well-known/acme-challenge/jkIAAwwatTmxg97JezQ-tC9JkTfHpio6LXJR8izssjE: DNS problem: NXDOMAIN looking up A for www.sub.domain.tld - check that a DNS record exists for this domain; DNS problem: NXDOMAIN looking up AAAA for www.sub.domain.tld - check that a DNS record exists for this domain

1 Like

I'm sure you mean a www prefix, not suffix. But with that said, it rather looks like sub.domain.tld is trying to redirect to www.sub.domain.tld, which fails due to the latter not having DNS records. But without your sharing the domain name, it's impossible to tell.


It is impossible to offer much in the way of help without a real domain name. The output you shared indicates that you have no DNS for the hostname, though. That will prevent you from obtaining a certificate.


You are right, I meant prefix, not suffix like I wrote.
Sorry for my bad English.

Your answers impled that it is possible to create a cert without www.-prefix.

So I disabled the SSL-Definition for that virtual host, and reloaded apache again.

Now it worked.

Thank you very much for your help!



Indeed it is.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.