Slow (20 seconds) initial load with SSL


#1

Here are a couple of screenshots of the chrome dev tools network timing tab from two isolated connections (this will only happen on the first load in a long while. Once the site is loaded it will usually load as far as expected (<1s) when refreshed)



The host is nearly free speech, server “type” is Apache 2.4 Static Content (No PHP, CGI, or Daemons), but no specific .htaccess/etc settings.
I am using this repo for letsencrypt automation: https://github.com/bearbin/nfsn-le

One of the domains this happens on: (but this does seem to happen with other domains on the same server and using the same automation repo): https://www.twoevelyns.com/

Any help of tips appreciated.

Thanks


#2

Sounds like the Apache server is either bottlenecking somewhere or SSL is not configured properly causing such a huge delay.

I dropped apache after a loyal 9 years and moved to Nginx due to Apache’s recent versions being very buggy and problematic with SSL and also slow server response times and bottlenecking issues which their user communities seemed most unwilling to help with.

Have you looked through all your Apache logs, especially the error logs to see what’s causing that very long response time ???


#3

I’ve never visited the site before, so not cached, and it loaded instantly ( about 0.3s) for me.


#4

Same here: no delay. Not in Chromium, not with OpenSSL and no issues at SSL Labs.


#5

Guess I should have mentioned these delays happen only once no one has visited the site for some duration, and they affect the loading speed thereafter globally.

So if no visits to the site occur within several hours, the first visit after this time would be a slow load, but other visits are not.

It’s weird, and hard to reproduce (because of the wait involved).


#6

Unfortunately with this host, I have no choice but to use apache, and don’t have access to any of the conf files.

Nothing weird is showing up in any of the apache logs (for long requests, they show up as normal entries in access.log)

I do know they are a relatively popular shared-hosting provider (nearlyfreespeech), and if the github repo I posted in the original post is any indication, others seem to use them with letsencrypt.


#7

Make sure that LogLevel is actually set correctly so you can see not only errors, but also warnings (which could be helpful). Also check the server status page (and probably check SSL settings, such as https://wiki.apache.org/httpd/SSLSessionCache)


#8

Hello @TernaryO,

I’ve no idea what the problem is but you should keep in mind that your site is accessed via a proxy that maybe is not configured properly:

$ curl -I https://www.twoevelyns.com/
HTTP/1.1 200 OK
Date: Sun, 25 Dec 2016 02:15:25 GMT
Server: Apache
Last-Modified: Sun, 11 Dec 2016 05:20:07 GMT
Accept-Ranges: bytes
Content-Length: 1841
Content-Type: text/html; charset=UTF-8
ETag: "731-5435b23ecf7b8"
Age: 0
Via: 1.1 vhost.phx5.nearlyfreespeech.net (squid)   <--- this is the proxy

I think you should open a support ticket to your hosting company explaining the issue… they should give to you more details and even a solution to your delay problem ;).

Good luck.

Cheers,
sahsanu


#9

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.