Site will not load using https

My certificate was created successfully. However, my website will not load using or

My domain is:

I ran this command:
certbot certonly --apache

It produced this output:
Saving debug log to /var/log/letsencrypt/letsencrypt.log
Plugins selected: Authenticator apache, Installer apache
Enter email address (used for urgent renewal and security notices) (Enter 'c' to
cancel): [redacted]

Please read the Terms of Service at You must
agree in order to register with the ACME server at

(A)gree/(C)ancel: A

Would you be willing to share your email address with the Electronic Frontier
Foundation, a founding partner of the Let's Encrypt project and the non-profit
organization that develops Certbot? We'd like to send you email about our work
encrypting the web, EFF news, campaigns, and ways to support digital freedom.

(Y)es/(N)o: Y

Which names would you like to activate HTTPS for?


Select the appropriate numbers separated by commas and/or spaces, or leave input
blank to select all options shown (Enter 'c' to cancel): 1 2
Obtaining a new certificate
Performing the following challenges:
http-01 challenge for
http-01 challenge for
Enabled Apache rewrite module
Waiting for verification...
Cleaning up challenges


  • Congratulations! Your certificate and chain have been saved at:
    Your key file has been saved at:
    Your cert will expire on 2023-02-10. To obtain a new or tweaked
    version of this certificate in the future, simply run certbot
    again. To non-interactively renew all of your certificates, run
    "certbot renew"

  • Your account credentials have been saved in your Certbot
    configuration directory at /etc/letsencrypt. You should make a
    secure backup of this folder now. This configuration directory will
    also contain certificates and private keys obtained by Certbot so
    making regular backups of this folder is ideal.

  • If you like Certbot, please consider supporting our work by:

    Donating to ISRG / Let's Encrypt: Donate - Let's Encrypt
    Donating to EFF: Support EFF's Work on Let's Encrypt | Electronic Frontier Foundation

  • We were unable to subscribe you the EFF mailing list because your
    e-mail address appears to be invalid. You can try again later by
    root@mds-enterprises:~# systemctl status certbot.timer
    ● certbot.timer - Run certbot twice daily
    Loaded: loaded (/lib/systemd/system/certbot.timer; enabled; vendor preset:>
    Active: active (waiting) since Sat 2022-11-12 14:44:59 UTC; 2min 46s ago
    Trigger: Sun 2022-11-13 06:08:13 UTC; 15h left
    Triggers: ● certbot.service

Nov 12 14:44:59 systemd[1]: Started Run certbot twice daily.

My web server is (include version):
Apache/2.4.41 (Ubuntu)

The operating system my web server runs on is (include version):
Ubuntu 20.04.5 LTS (GNU/Linux 5.4.0-131-generic x86_64)

My hosting provider, if applicable, is:

I can login to a root shell on my machine (yes or no, or I don't know):

I'm using a control panel to manage my site (no, or provide the name and version of the control panel):

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you're using Certbot):
certbot 0.40.0

You're using the certonly subcommand which will, well.. Get you only a cert. And won't install it.

Remove certonly and when Certbot asks you to install the already issued certificate say Yes.


Thank you. Everything is working fine.


I'm not seeing a certificate on the site.


I do when using https:// for apex and www subdomain.

But, I don't see a redirect from http to https

The cert used is the most recent so that's good. Although I hope they don't keep getting fresh certs a couple times / day like they have been.


Gotcha! No redirect. I see the cert now. Should have looked closer before.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.