Site Not Secure after Lego auto install

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. https://crt.sh/?q=example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is: www.maisonclermont.com

I ran this command: sudo /opt/bitnami/letsencrypt/scripts/generate-certificate.sh -m YOURMAIL -d YOURDOMAIN
It produced this output: created my certificate but only maisonclermont.com (not www) so now the site says not secure when typed into a browser

My web server is (include version): Wordpress on AWS Lightsail (apache / Nginx) i think

The operating system my web server runs on is (include version):

My hosting provider, if applicable, is: AWS Lightsail

I can login to a root shell on my machine (yes or no, or I don’t know): yes SSH

I’m using a control panel to manage my site (no, or provide the name and version of the control panel): no

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you’re using Certbot): don’t know

I realize that I didn’t add both domain names on the original auto lego install and now do not know how to perform a manual install (too advanced for me, sorry)

Thanks in advance

I don't have any experience with Lego, but shouldn't you also add the www subdomain with a second -d option on that command line?

It seems there are two certificates, one for maisonclermont.com and one for www.maisonclermont.com.

https://crt.sh/?q=%maisonclermont.com

So you just have to set up two Apache virtual hosts, one for each name.

Or get a new certificate for both names and delete the others.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.