Site not loading after installing certbot letsencrypt ssl

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. https://crt.sh/?q=example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is: sportsup.com.ng

I ran this command: The site was working fine then i choose to install certbot letsencrypt ssl

It produced this output: Then the site stop loading and i can't access my wordpress backend

My web server is (include version): Debian (9.13)

The operating system my web server runs on is (include version): Debian (9.13)

My hosting provider, if applicable, is: google cloud

I can login to a root shell on my machine (yes or no, or I don't know): Yes

I'm using a control panel to manage my site (no, or provide the name and version of the control panel):

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you're using Certbot):

1 Like

Your site is suffering from a redirect loop.

This can sometimes happen if you're running behind Cloudflare and have an HTTP-to-HTTPS redirect setup, which Certbot does automatically now.

The redirect malfunctions because it doesn't understand that Cloudflare is sitting in front of your site.

One way to fix this is to go into your Cloudflare security settings (https://support.cloudflare.com/hc/en-us/articles/200170416-End-to-end-HTTPS-with-Cloudflare-Part-3-SSL-options) and make sure the SSL option is set to "Full".

1 Like

Hi @richkid

checking your domain you have two loops - https://check-your-website.server-daten.de/?q=sportsup.com.ng

 https://sportsup.com.ng/ ->  https://sportsup.com.ng/
 https://www.sportsup.com.ng/ ->  https://www.sportsup.com.ng/

So first step: Find and remove these loops.

That's not a command. Your exact command is required.

1 Like

Thank you for your timely response the site is responding now after i follow your instruction but it seems the SSL is not working because the lock is not showing.

Thank you.

2 Likes

Glad to see that you fixed the redirect loop.

The SSL is working, but your browser complains because of something called mixed content.

It basically means that your site is coded in a way where it still loads some element (scripts, images, etc) insecurely.

This can be a problem with your WordPress theme, or something else.

You can use this tool to figure what parts of your site you need to fix up before the mixed content warnings will go away: https://www.whynopadlock.com/results/2707d136-16ea-4715-a223-28ab578aec5f

For example:

An image with an insecure url of "http://35.222.127.3/wp-content/uploads/2019/12/home-new-bg-free-img.jpg" was loaded on line: 744 of https://sportsup.com.ng/.

Most likely this URL will be somewhere in your WordPress database, so you will need to locate and update it to use be an point to https://sportsup.com.ng/wp-content/uploads/2019/12/home-new-bg-free-img.jpg instead.

Rinse and repeat.

3 Likes