Setup XAMPP on Debian with Certbot

Hi,

I have installed XAMPP on a Debian server and it's working: http://techtest.freemyip.com

I tried setting up SSL using certbot. I tried following several instructions like this one:

It suggests commenting all ports both 80 and 443 from the file /etc/apache2/ports.conf.

However, I don't have this file on my system.

When running certbot I get the following error.

sudo certbot --apache-ctl /opt/lampp/bin/apachectl
Saving debug log to /var/log/letsencrypt/letsencrypt.log
ssl_module is statically linked but --apache-bin is missing; not disabling session tickets.

I believe the instructions may have worked at one point, but are not working anymore.

What do you have running on port 80?

You can use certbot --standalone if you have no webserver. Otherwise you can use --webroot.

Remember to use the appropriate --deploy-hook for your xmpp server.

Please ignore the above, I read xmpp instead of xampp.

You should not be using xampp over the internet. The error message is telling you to provide the path to the Apache executable with the --apache-bin option. You could do that.

But using xampp instead of Apache itself as managed by Debian is what I'd call "making stuff harder for yourself"

4 Likes

That's good advice. Then I shall use components of Debian repo instead.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.