Setting up a free SSL with SmarterASP

My domain is: northman.com

I ran this command: sudo certbot certainly --manual

It produced this output:Waiting for verification…
Cleaning up challenges
Failed authorization procedure. nortiman.com (http-01): urn:acme:error:connection :: The server could not connect to the client to verify the domain :: Fetching http://nortiman.com/.well-known/acme-challenge/RdB32d5tW3-lMJ3HuINTmkgbBM07oKktSFs8UZw182Y: Timeout

IMPORTANT NOTES:

  • The following errors were reported by the server:

    Domain: nortiman.com
    Type: connection
    Detail: Fetching
    http://nortiman.com/.well-known/acme-challenge/RdB32d5tW3-lMJ3HuINTmkgbBM07oKktSFs8UZw182Y:
    Timeout

    To fix these errors, please make sure that your domain name was
    entered correctly and the DNS A/AAAA record(s) for that domain
    contain(s) the right IP address. Additionally, please check that
    your computer has a publicly routable IP address and that no
    firewalls are preventing the server from communicating with the
    client. If you’re using the webroot plugin, you should also verify
    that you are serving files from the webroot path you provided.

My web server is (include version): Not sure, but website is hosted by SmarterAsp.Net

The operating system my web server runs on is (include version): See above

My hosting provider, if applicable, is: SmarterAsp.Net

I can login to a root shell on my machine (yes or no, or I don’t know): I don’t know

I’m using a control panel to manage my site (no, or provide the name and version of the control panel): No

northman.com” is not equal to “nortiman.com”. Which domain name is the right one?

Think that must have been an auto correct! The domain is:
nortiman.com

I don’t see a timeout issue here, since the webserver at least answers the request. What I find surprising: you use certbot, but the webserver behind the domain name identifies itself as Microsoft IIS.

I’m not sure I follow - why is that odd?

It’s an ASP.NET / MVC based website - am I going about this all wrong?

I haven’t tried to be fair, but I don’t think Certbot plays well on Windows, generally. Usually people use one of the Windows clients in tandem with IIS.

I’m running CertBot via Terminal on my Mac, does this impact things? I seem to be going in circles on this as I can’t see anything wrong with what I’m doing yet I’m having no luck getting past the stage above.

use a client like certify on the server as it will do all the configurations for you

also have a look at part 3 and 4 of this article: https://www.linkedin.com/pulse/lets-encrypt-part-1-issuing-installing-certificates-andrei-hawke/

If you insist to continue on your path (I would), ensure that the Internet can properly reach files located in the acme-challenge folder.
To that end, please place a brief test.txt file at: http://nortiman.com/.well-known/acme-challenge/test.txt

This won’t work here out of the box. The op uses certbot on an unrelated system, so he has to copy the acme-challenge to the right path on the iis webserver.

@fentimanj: certbot is primarily meant to be used on the server which hosts the domain(s) and does not support windows systems. If you want to issue certificates on your windows server, you should use another client.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.