Server crashed & certificates lost


#1

Hello,

I have a dedicated server with an Apache server and a Let’s Encrypt SSL certificate. All was good before my server crashed and I lost all my data (HDD dead), including my SSL certificate and private key. I have always the same physical server and the same IP.
I tried to install a new certificate by the same way and it worked BUT now my browser throw a security issue warning.

I think there is a mismatching between the old certificate and the new one I just generate. Am I right ?
If I am, how to recover my old certificate or to make the new one to overwrite the old ?

Here some infos:

My domain is: lacoquetteriedemathilde.com
My web server is (include version): Apache
The operating system my web server runs on is (include version): debian 9.4
I can login to a root shell on my machine (yes or no, or I don’t know): yes

Thank’s for your service and your help,
Florian.


#2

The installed certificate is for lacoquetteriedemathilde.fr .

You need to issue one also for lacoquetteriedemathilde.com.

You can issue one for both at once, if you like:

certbot --apache -d lacoquetteriedemathilde.fr \
-d lacoquetteriedemathilde.com

#3

Thank you very much :slight_smile: It works.


#4

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.