Self Signed on new VPS with (Debian 10 / LAMP / ISPConfig 3.2)

Hey guys

A few weeks ago I started testing with ISPConfig 3.2.

I installed on a DigitalOcean VPS: Debian 10 + Apache2 + PHP + MariaDB + ISPConfig.
As an additional background I mention that the ISPConfig installer includes acme sh (not certbot)
Everything worked perfect. SSL certificates both in the subdomain of the Control Panel (ISPConfig) and in the domains that I added later.

A few days ago I started with the same tests, now on a Namecheap VPS.
Exactly the same installation (same versions and same installation steps).
The only problem is that the SSL certificates are not valid (Self Signed).

Is it because Namecheap does not offer IPv6 support?
It is the only big difference that I find with respect to DigitalOcean

Another cause (I wonder) could it be that I used the same domain?
In DigitalOcean I configured everything to using one IP and now I am configuring everything to the same but with another IP.

This is the SSL check of my url

Url of my Panel (ISPConfig)

Any Idea?

My domain is:

I ran this command: ISPConfig Installer (acme sh)

It produced this output: Self Signed

My web server is (include version): Apache 2.4.38

The operating system my web server runs on is (include version): Debian 10

My hosting provider, if applicable, is: Namecheap

I can login to a root shell on my machine (yes or no, or I don't know): yes

I'm using a control panel to manage my site (no, or provide the name and version of the control panel): ISPConfig 3.2

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you're using Certbot): acme sh (included on ISPConfig installer)

1 Like


results: You have created a new certificate, but you don't use it.

So install it on your port 8080.

How? I don't know, that's a pure ISP Config problem -> ask in a specialized forum.

Your port 443 is a http port, not a https port.

has the default Apache page.

Thanks JuergenAuer
It's very strange
In my previous installation (on DigitalOcean), the certificate worked perfectly on port 8080, which is the one used by ISPConfig.
And it doesn't work on Namecheap.
I will keep investigating and I will comment if I can fix it.
Thanks again.

1 Like

Welcome to the Let's Encrypt Community :slightly_smiling_face:

This sounds like it could be an apache configuration issue.

What says this?

sudo apachectl -S

Please put 3 backticks on lines above and below the output, like this:


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.