Selecting a LetsEncrypt Client for OpenBSD 6.0


#1

So far none of the guides have worked at all. The typical LE source from github where you use ‘letsencrypt-auto certonly’ is incapable of recognizing that OS. Although, I did initially run that on 5.8 and was able to get a cert on OpenBSD during testing over 6 months ago.

Instead, it is now recommended to use the -current branch of 6.0 (which I am not), or use acme-client. acme-client is incapable of working as well:

acme-client: /etc/acme/privkey.pem: account key exists (not creating)
acme-client: /etc/ssl/acme/private/privkey.pem: domain key exists (not creating)
acme-client: /etc/ssl/acme/private/privkey.pem: PEM_read_PrivateKey
2256225808:error:0906D06C:PEM routines:PEM_read_bio:no start line:/usr/src/lib/libcrypto/crypto/../../libssl/src/crypto/pem/pem_lib.c:704:Expecting: ANY PRIVATE KEY
acme-client: bad exit: keyproc(33902): 1

I have used this guide and followed it the letter, but it does not work whatsoever.

Also have tried this one too.

Has anybody installed a cert on OpenBSD 6.0?


#2

try https://github.com/Neilpang/acme.sh , it supports openbsd.


#3

@n1n2

can you do me a favour and run the following commands

python --version
pip freeze

this will tell me if your OpenBSD install can obtain Cerbtot via the Python PIP Package Manager

Andrei


#4

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.