RSA server certificate CommonName (CN) `Plesk' does NOT match server name!?


Good evening, I install on my server so lets encrypts on my domain name all my works on my subdomain that my error me

Erreur: Échec de l’installation du certificat SSL Let’s Encrypt : Failed letsencrypt execution: Saving debug log to /usr/local/psa/var/modules/letsencrypt/logs/letsencrypt.log
Starting new HTTPS connection (1):
Obtaining a new certificate
Performing the following challenges:
http-01 challenge for
Starting new HTTPS connection (1):
Waiting for verification…
Cleaning up challenges
Failed authorization procedure. (http-01): urn:acme:error:unauthorized :: The client lacks sufficient authorization :: Invalid response from "<!DOCTYPE HTML PUBLIC “-//IETF//DTD HTML 2.0//EN”>
<title>404 Not Found</title>
<h1>Not Found</h1>

  • The following errors were reported by the server:

Type: unauthorized
Detail: Invalid response from
<title>404 Not Found</title>
<h1>Not Found</h1>

To fix these errors, please make sure that your domain name was
entered correctly and the DNS A record(s) for that domain
contain(s) the right IP address.

other error

RSA server certificate CommonName (CN) `Plesk’ does NOT match server name!?


Up !..pleas


It was trying to obtain confirmation from and failed. The server returned a “404 Not Found” error.

This could be because the domain ( is incorrect, or it could be that the token has been placed in the wrong location.

What command were you running ?


I know him so Plesk uses that manages all

I do not understand this error it drives me crazy

step 1:
step 2:
step 3: (Error)


Hi @Dzeus, I think this is probably a problem with Plesk’s Let’s Encrypt support. Maybe you could ask the Plesk developers or whoever installed or manages Plesk in your hosting environment?


Hi Dzeus

You challenge is the folder and the file is not found.

If you browse to

You get a 404 error. First you need to create the.acme folder at your root and make sure that it is available to the internet.

I.e. i should be able to browse to: and not get an error (this is a web configuration error)

Second of all you need to make sure that you can server up a file without an extension. If you create a file in that folder calle test (no extension) and fill it with some text you should be able to browse to and the browser should display the content of that file.

I also notice you are using CloudFlare. You may want to disable it temporarily as it may be blocking letsencrypt (if it classifies it as a robot). Not sure if this is happening but if you are able to get a file via the browser but not via letsencrypt it could be something to check.


The acme-challenge directory doesn’t necessarily have to exist all the time. Certbot is happy to create, delete, recreate and redelete it on demand. Although it may be good to confirm that it works.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.