Revoking Certificate

I forgot to set a static IP before I requested the certificate, I've since fixed that but the certificate points to an incorrect location. I need to revoke the certificate.

My domain

I ran this command: I created a certificate but I want to revoke it. I went through the process of deleting the crontab, deleting the certificates, relinking bitnami stack to use the default certs as described in the documentation.

It produced this output: I am still seeing the certificate as valid when I do the DNS look up (although my email address wasn't verified). I then realized I could have revoked the certificate if I had kept the private key but I can't get that file anymore.

My web server is (include version): Apache/2.4.52 (Unix)

The operating system my web server runs on is (include version): 4.19.0-20-cloud-amd64 (bitnami stack)

My hosting provider, if applicable, is: AWS

I can login to a root shell on my machine (yes or no, or I don't know): Yes

I'm using a control panel to manage my site (no, or provide the name and version of the control panel): No

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you're using Certbot): I don't have certbot, I used the bncert tool on bitnami to create the certificate.

Can you please help me revoke this certificate so I can start over? Thank you. Have a great day!

No need to revoke certificate unless its key is compromised. Just create another one, if its key is permanently lost. However, keep in mind that there are certificate's creation rate-limits.


Thank you @bruncsak, when I tried to create a new certificate it told me to remove the old configuration to avoid issues so I got confused. Will give this a try.

1 Like

For all future readers:
"remove" and "revoke" are quite different.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.