Revert to http access with Apache2 on Unbuntu 18.04

Hi Ive contracted the Wordpress 5.4.1 upgrade site health blues! After exhausting lots of options I want to roll back certbot installation to see if the errors produced are there when ssl disabled

Here are the site health issues on WordPress 5.4.1 2017 theme. PHP version: 7.4.5

  1. The REST API encountered an error

  2. Your site could not complete a loopback request

  3. Only parts of your site are using https

  4. Background updates are not working properly

My domain is:

I ran this command: certbot rollback

It produced this output:
Saving debug log to /var/log/letsencrypt/letsencrypt.log
2020-05-11 12:52:19,695:DEBUG:certbot.main:certbot version: 0.31.0
2020-05-11 12:52:19,696:DEBUG:certbot.main:Arguments:
2020-05-11 12:52:19,696:DEBUG:certbot.main:Discovered plugins: PluginsRegistry(PluginEntryPoint#apache,PluginEntryPoint#manual,PluginEntryPoint#null,PluginEntryPoint#standalone,PluginEntryPoint#webroot)
2020-05-11 12:52:19,703:DEBUG:certbot.log:Root logging level set at 20
2020-05-11 12:52:19,703:INFO:certbot.log:Saving debug log to /var/log/letsencrypt/letsencrypt.log
2020-05-11 12:52:19,785:DEBUG:certbot_apache.configurator:Apache version is 2.4.29
2020-05-11 12:52:20,129:DEBUG:certbot.plugins.selection:Single candidate plugin: * apache
Description: Apache Web Server plugin
Interfaces: IAuthenticator, IInstaller, IPlugin
Entry point: apache = certbot_apache.entrypoint:ENTRYPOINT
Initialized: <certbot_apache.override_debian.DebianConfigurator object at 0x7fac2ff0d048>
Prep: True

My web server is (include version): Apache/2.4.29 (Ubuntu)

The operating system my web server runs on is (include version):Ubuntu 18.04

My hosting provider, if applicable, is: DigitalOcean

I can login to a root shell on my machine (yes or no, or I don’t know):Yes

I’m using a control panel to manage my site (no, or provide the name and version of the control panel):no

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you’re using Certbot): 0.31.0

Any help much appreciated

1 Like

Hi @swampy

checking your domain via you have

  • a working http
  • a working https, your certificate is valid
  • only two small mixed content errors:

Change both links to https, then (3) is done.

The other errors - no idea what that is.

Looks like this isn’t http / https specific.

And https is the future, so you should use it. A rollback to http is the wrong way.

1 Like

Thanks Juergen for that info and directing me to the check server website
I can locate the files but Im really struggling to find where the offending http code is so I can edit it
Have used grep but still no luck
Will continue that search and will also post to a Wordpress support site
I had read that someone else with these problems had reverted to http and the problem had disappeared so just wanted to see if it behaved like that for me
I have no intention of permanently removing ssl from any of the sites I manage - LE is a great product

That’s a Wordpress problem, may be an Addin. Another user uploaded the files again, that fixed the problem. But I don’t use Wordpress, so I don’t know how that works.

Thanks again for your support - I wish i never decided to do Wordpress I mainly work with Joomla - WP is front end user friendly but with maintenance when things go wrong with updates particularly it seems to be very hard to fix
I shall mark this resolved

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.