Return code: 400

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. crt.sh | example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is:dm.mcgm.gov.in

I ran this command:

It produced this output: Return code: 400Details: Fetching http://dm.mcgm.gov.in/.well-known/acme-challenge/C8VjWC-mDscBQL1oCTTFMLfzJ3t3UXI_NthSFBHPsuU: Timeout during connect (likely firewall problem)

My web server is (include version): Apache/2.4.6

The operating system my web server runs on is (include version):centos 7

My hosting provider, if applicable, is:ISPManager

I can login to a root shell on my machine (yes or no, or I don't know): yes

I'm using a control panel to manage my site (no, or provide the name and version of the control panel): ISPmanager Lite 6.43.1

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you're using Certbot):

I cannot reach this website either.

Although I don't know what acme client is ispmanager using under the hood, a website needs to be globally reachable to be verified using http-01.

2 Likes

The panel ISPmanager uses the C ACMEv2-client specially designed for it.

You are mostly likely blocking traffic from outside India, or TCP port 80 just isn't open (for http). If you need to block for either reason then you will need to use DNS validation instead of HTTP validation for your domain.

2 Likes

It looks like you are indeed blocking traffic from outside of India.


made on this website

http-01 validation does not work if you block connections from the rest of the world. You have three options:

  1. allow connections from the rest of the world, always
  2. allow connections from the rest of the world, only during validation (certbot has --pre-hook and --post-hook that you can use to issue commands to your firewall, I don't know your client)
  3. use the dns-01 challenge instead of http-01 as @webprofusion said. be aware that if the same firewall is protecting your authoritative nameserver, dns-01 will fail as well.

It looks like your authoritative nameservers (one of them, at least) responds to me.

$ dig @dns5.tatacommunicationsdns.com. a dm.mcgm.gov.in

; <<>> DiG 9.18.0-2ubuntu2-Ubuntu <<>> @dns5.tatacommunicationsdns.com. a dm.mcgm.gov.in
; (1 server found)
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 25887
;; flags: qr aa rd; QUERY: 1, ANSWER: 1, AUTHORITY: 5, ADDITIONAL: 6
;; WARNING: recursion requested but not available

;; OPT PSEUDOSECTION:
; EDNS: version: 0, flags:; udp: 4096
;; QUESTION SECTION:
;dm.mcgm.gov.in.                        IN      A

;; ANSWER SECTION:
dm.mcgm.gov.in.         14400   IN      A       59.163.51.179

;; AUTHORITY SECTION:
mcgm.gov.in.            86400   IN      NS      dns2.tatacommunicationsdns.com.
mcgm.gov.in.            86400   IN      NS      dns5.tatacommunicationsdns.com.
mcgm.gov.in.            86400   IN      NS      dns3.tatacommunicationsdns.com.
mcgm.gov.in.            86400   IN      NS      dns1.tatacommunicationsdns.com.
mcgm.gov.in.            86400   IN      NS      dns4.tatacommunicationsdns.com.

;; ADDITIONAL SECTION:
dns1.tatacommunicationsdns.com. 14400 IN A      115.112.250.115
dns2.tatacommunicationsdns.com. 14400 IN A      195.219.235.85
dns3.tatacommunicationsdns.com. 14400 IN A      209.58.67.115
dns4.tatacommunicationsdns.com. 14400 IN A      66.198.171.70
dns5.tatacommunicationsdns.com. 14400 IN A      121.241.244.165

;; Query time: 250 msec
;; SERVER: 121.241.244.165#53(dns5.tatacommunicationsdns.com.) (UDP)
;; WHEN: Fri Feb 25 11:27:36 CET 2022
;; MSG SIZE  rcvd: 259
2 Likes

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.