Challenge failed for domain

Type: connection
Detail: Fetching bMBzDci8g0iKE8ln8E:
Error getting validation data

I dont know why have this problem,can someone help me?

1 Like

Please share the entire output and also the answers to the following questionnaire, which you should have gotten when starting a thread in the #help section:

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. |, so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is:

I ran this command:

It produced this output:

My web server is (include version):

The operating system my web server runs on is (include version):

My hosting provider, if applicable, is:

I can login to a root shell on my machine (yes or no, or I don't know):

I'm using a control panel to manage my site (no, or provide the name and version of the control panel):

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you're using Certbot):

Further more, your website is unreachable at the moment. When using the http-01 challenge, a working HTTP website on port 80 is required.


Sorry if i not describe all the fields.
i run this command on my centos 7 all update with yum

Saving debug log to /var/log/letsencrypt/letsencrypt.log
Plugins selected: Authenticator apache, Installer apache
Starting new HTTPS connection (1):

Which names would you like to activate HTTPS for?
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Select the appropriate numbers separated by commas and/or spaces, or leave input
blank to select all options shown (Enter 'c' to cancel): 1
Requesting a certificate for
Performing the following challenges:
http-01 challenge for
Waiting for verification...
Challenge failed for domain
http-01 challenge for
Cleaning up challenges
Some challenges have failed.

 - The following errors were reported by the server:

   Type:   connection
   Detail: Fetching
   Error getting validation data

   To fix these errors, please make sure that your domain name was
   entered correctly and the DNS A/AAAA record(s) for that domain
   contain(s) the right IP address. Additionally, please check that
   your computer has a publicly routable IP address and that no
   firewalls are preventing the server from communicating with the
   client. If you're using the webroot plugin, you should also verify
   that you are serving files from the webroot path you provided.

i connnect with ssh perfectly and i used lets encrypted just 1 year, the problem appended last dicember , i dont know why
this is thw version of certbot

certbot 1.11.0

the site is reachable for with blank page is correct.

1 Like

I'm getting a time out. Other sites on the web confirm this:

A working HTTP website on port 80 is required when using the http-01 challenge. Sometimes locally a site works, but internationally, it doesn't.

Other examples showing the site being down:


maybe less is reachable
but is not reachable right.

Currently, I see a redirect from HTTP to HTTPS.


i resolve my problem with this command
sudo firewall-cmd --add-service=http --permanent

thanks to all

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.